none
adding trusted location on Remote Server doesn't prevent throwing security warning RRS feed

  • Question

  • I'm used to deploying Access runtimes and adding a location via the Trust Center (or a .reg file the installer can double-click on). But when I try this with Access 2016 on a Remote Server, nothing I do ever makes the security warning not appear.

    Security Notice

    I've tried a couple of different folders, including C:\myFolder and C:\users\userName\Documents.

    Any ideas how to suppress this message from a Remote Server?

    Wednesday, February 15, 2017 9:40 PM

Answers

  • Ok, here's the answer.

    Right clicking on the Access file, I chose "open with" and it turns out both Access 2010 runtime and the full Access 2016 are on the computer (this is a server -- there's a lot of stuff on it, a lot of people are logging in to it, expecting different versions of several things). It had been starting with the Access 2010 runtime. I kept updating the Access 2016 permissions. Once I set the Access file to open with Access 2016, everything behaves.

    Sorry for running everyone through this wild goose chase. Thanks for the ideas, though.


    Thursday, February 16, 2017 10:13 PM

All replies

  • Hi,

    I think the file path should look like \\server\share instead of a local file path when you add its location via Trust Center.

    Regards

    Celeste


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, February 16, 2017 7:20 AM
    Moderator
  • No luck. But maybe I'm doing something wrong. 

    Trusted Locations

    The Remote Server doesn't have any public shares -- do I need to create one to then reference, is that what you meant? I tried the C$, should that work? 

    Thursday, February 16, 2017 1:29 PM
  • just to be clear when you say: try this with Access 2016 on a Remote Server

    you are attempting to trust a folder, and that folder is on a drive (on a LAN connected Server) that can be selected via the browse feature.....

    you are not attempting to trust the server itself .......

    Thursday, February 16, 2017 2:27 PM
  • I think we're talking about two different things here. Sorry about that.

    I'm running a Remote Desktop Connection session to a Remote Server computer. So the user's C:\ and %Documents% and etc. are all on the C:\ of the Remote Server. I don't think I should need network shares to access the same C:\, see what I mean? It seems like if I can copy files from a network share into the user's %Documents%\Tekhelps folder, I should be able to just tell Access to trust that same %Documents%\Tekhelps folder. But that's what doesn't work.

    Maybe there's something about a shared copy of Access on the Remote Server that doesn't work the way I think it should, or something like that.

    Any ideas greatly appreciated. Or if I'm not explaining this fully enough, let me know.

    Thanks.



    Thursday, February 16, 2017 2:52 PM
  • one would not use the local Access application

    if you remote to an Access file - use the Access application at that remote location i.e. a virtual deskop...

    Thursday, February 16, 2017 3:13 PM
  • I'm using Access at the remote location. MSACCESS.EXE is running on the remote server, the .accdb file is on the same remote server. But the remote copy of Access doesn't trust the .accdb that's on the same computer it's on.
    Thursday, February 16, 2017 3:16 PM
  • ah okay then...

    so as a remote user - - in the destination folder where the back end file is sitting:

    copy in a Word doc or Excel doc

    open that doc, edit it, save it

    ... see if you can do those tasks.  I use this as a sanity check because Access linking really tends to blow the circuits of networking guys sometimes for some reason.  If you can't work with a simple Word or Excel doc in that folder then there is a permissions issue involving folder rights or network rights

    .... this is just a sanity check - but that's what I would do next....

    Thursday, February 16, 2017 3:29 PM
  • I was able to create, save, open Word documents in this folder and its parent.

    word document

    Opening the Access document still throws the warning.

    I know it's running Access from the Remote Server, because Access 2016 isn't even installed on the computer that's running the RDC session.

    Thursday, February 16, 2017 5:33 PM
  • Just wondering - do you end up with the security bar - when you open an Access application - - which allows you to enable for the current session ? ... or does that first pop up go away and it opens without the security bar?

    Another thought: for any file (Access, Word, Excel, etc) one can right click, select Properties - and sometimes on the right side of the Properties pop up is an option to check to Unblock.  This is true for instance if I have saved a file that was an email attachment but not if I move it from another folder. What happens when you try that?

    Thursday, February 16, 2017 7:45 PM
  • When you set up your trusted locations did you check the box to "allow trusted locations on my network" It's in the bottom left corner of the dialogue box.

    Bill Mosca
    www.thatlldoit.com
    http://tech.groups.yahoo.com/group/MS_Access_Professionals

    Thursday, February 16, 2017 9:23 PM
  • I don't see the security bar when Access starts. If I answer "Open" in the dialog, everything seems to work. If I answer "Cancel", Access doesn't start.

    I tried "right click" on the Access file but no "blocked" option.

    Thursday, February 16, 2017 10:11 PM
  • Ok, here's the answer.

    Right clicking on the Access file, I chose "open with" and it turns out both Access 2010 runtime and the full Access 2016 are on the computer (this is a server -- there's a lot of stuff on it, a lot of people are logging in to it, expecting different versions of several things). It had been starting with the Access 2010 runtime. I kept updating the Access 2016 permissions. Once I set the Access file to open with Access 2016, everything behaves.

    Sorry for running everyone through this wild goose chase. Thanks for the ideas, though.


    Thursday, February 16, 2017 10:13 PM