none
Cannot get a newly created VSTO Outlook Add In to Load RRS feed

  • Question

  • I may have solved this myself, not fully sure but the add-in can now be checked without the run time error.

    One more issue was located, suggesting VSTO 3.0.  However, this is ONLY for Office 2007, etc. and was needed at one point.  Probably, all versions of VSTO should play well in the sandbox but here is what has cleared up the app not loading: Removing any VSTO versions not needed, including removing and re-adding VSTO 2005 SE.

    I've left the other text as is.  Perhaps folks having issues like this one might need to remove any unused VSTO versions?  Maybe that's extreme -- I'm just saying I'm to first base now.

    I'll leave this open if anyone has other input that might be of use.

    Original post text as of 17:08 today follows:

    I've tried just about everything that is mentioned in this link: http://social.msdn.microsoft.com/Forums/en-US/vsto/thread/add59a20-9775-44be-a33e-77ac593e01ff/ to no avail.

    Mentioned here however is this:

    We've finally gotten to the bottom of this.  The problem was that the permissions on HKCR\VSTOInterop.InteropAppDomainManager were incorrect.  There was no ACE for the built-in Users account and the built-in Administrator's account only had Read control.  Resetting the appropriate permissions resolved the issue.

    Geoff Darst

    Microsoft VSTO Team

    This is great but I have no idea how to DO this.  If this is indeed the issue, WHERE is this reset at?

    I have created a simple C# Add In Project and before adding any code, I'm just trying to get it to load into Outlook.  I'm using VS 2008, Office 2003.

    Do I have it right that CAS only matters when the project is deployed to an end user machine?  That is, to get it to debug it should write the dll to a known location, which can be loaded then by Outlook?

    At any rate, the persistent and nefarious "Not Loaded.  A runtime error occurred during the loading of the COM Add In."  And NO post, NOTHING else is resolving it.

    The project builds, Outlook does in fact detect it.  It can even be checked during debug.  That is, Outlook starts up.  I can of course Nav to the dialog box for selecting the add in.  I can check it, click apply/OK and so on. 

    But pulling the dialog back up shows the above error.

    I've spent the last week trying the methods suggested on many posts already.  No joy.

    Thanks for any help.


    Michael Durthaler


    • Edited by SACSgtMike Saturday, October 13, 2012 9:34 PM
    Saturday, October 13, 2012 8:40 PM

Answers