locked
Where does Blend get control list for the Project Controls in the toolbox? RRS feed

  • Question

  • At the top of my list of 239482390478453403 aggravating blend bugs and missing features is the inability to create user controls that work in the designer.

    I can create a user control, put it in my XAML, and the program runs fine, however Blend and VS both refuse to load the control in the designer.

    Sometimes i can drop the projects in a new solution and the designer will work, but the controls won't show up in the toolbox.

    Sometimes I can create a WPF control library and all of my controls appear... but new ones won't appear. Dropping them into a new library doesn't always work, either. It varies solution to solution.

    I'm tired of spending hours reorganizing my files trying to "trick" WPF into working like it should. Has anyone else experienced this and found a consistent workaround? Is this a bug MS is aware of?

     

    • Moved by Min Zhu Wednesday, December 1, 2010 2:20 AM (From:Windows Presentation Foundation (WPF))
    Tuesday, November 30, 2010 9:16 PM

All replies

  • Hi Robert,

    Thank you for your feedback!

    It appears that this is an Expression Blend related question so I have moved it to Expression Blend forum.

    You can also start a thread at WPF Designer forum for questions related to WPF designer in Visual Studio.

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.

    Have a nice day!

    Best regards,

    Min

    MSDN Subscriber Support in Forum
    If you have any feedback of our support, please contact
    msdnmg@microsoft.com.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, December 1, 2010 2:19 AM
  • Can you share the control causing the problem so we can investigate?
    Wednesday, December 1, 2010 2:26 PM
    Moderator
  • Can I e-mail you the solution? No NDA required, but it's not something I'm willing to post.

    You can reach me at robert dot bouillon at gtech dot com.

    Wednesday, December 29, 2010 12:22 AM
  • Sure, first.last@microsoft.com using my name.
    Tuesday, January 4, 2011 2:48 PM
    Moderator