none
Microsoft 3.5 Framework Setup Issues RRS feed

  • Question

  • Hello,

    I have been trying to download and install .NET Framework 3.5 for quite awhile now and have been looking at different solutions to this problem. I have already tried to use the cleanup tool for .NET programs, it hasn't worked. I have also tried installing each .NET Framework from 1.0- 3.5. It will install correctly from 1.0- 2.0, but when I try to install framework 3.0 and on (besides 4.0) it will not install. Here is my error codes-

    "[07/09/10,23:04:21] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] Failed to fetch setup file in CBaseComponent::PreInstall()

    [07/09/10,23:04:21] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.

    [07/09/10,23:04:21] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed

    [07/09/10,23:04:21] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults

    [07/09/10,23:04:21] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]

    [07/09/10,23:04:21] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()

    [07/09/10,23:04:21] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()

    [07/09/10,23:04:22] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed

    [07/09/10,23:04:22] WapUI: [2] DepCheck indicates Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86) is not installed.

    [07/09/10,23:04:23] WapUI: [2] DepCheck indicates RGB Rast was not attempted to be installed.

    [07/09/10,23:04:23] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a was not attempted to be installed.

    [07/09/10,23:04:23] WapUI: [2] DepCheck indicates XPSEPSC Installer was not attempted to be installed.

    [07/09/10,23:04:23] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 was not attempted to be installed.

    [07/09/10,23:04:23] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.

    [08/03/10,20:52:37] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603

    [08/03/10,20:52:53] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.

    [08/03/10,20:57:13] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603

    [08/03/10,20:57:33] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.

    [08/03/10,21:16:56] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603

    [08/03/10,21:17:13] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.

    [08/03/10,21:35:06] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603

    [08/03/10,21:35:20] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.

    [08/03/10,21:46:07] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603

    [08/03/10,21:46:25] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.

    [08/03/10,22:03:23] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603

    [08/03/10,22:03:43] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.

    [08/03/10,22:24:45] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603

    [08/03/10,22:25:04] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed."

    Any suggestion will be appreciated.

    Thanks for you're time.

    -Kyle


    Sunday, August 8, 2010 12:15 AM

Answers

  • Hi sliceanddic3,

    Thank you for your post in MSDN forum!

     

    Some clarification with you

    1, what is your OS?

    2, have you installed Windows XP SP2 on your machine?

     

    If not, you could get it from the following link and install it on your machine.

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=893fd6c0-6283-44c3-bb84-b2f0315b2ae6

    As your error information, I found some errors as follows.

    [08/03/10,20:52:37] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603

    [08/03/10,20:52:53] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.

    The 1603 error code is returned when any action fails during an installation, and most commonly it indicates that

    one of the custom actions in the MSI failed.

    You could refer the following blog. You will get more helpful suggestions.

    http://blogs.msdn.com/b/astebner/archive/2005/08/01/446328.aspx

     

    If it does not work, you could refer your log files to narrow down your issue.

    Or you could send your log files to me. (My E-Mail: v-xugong@microsoft.com)

    Note: Please attach the link of this post in the mail.

     

    Look forward for your good news!

    Best Regards

    Larcolais Gong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, August 9, 2010 9:39 AM

All replies

  • None of that worked, I also should have stated that I'm running Windows XP. Sorry.

    Thanks for the suggestion, though.

    -Kyle

    Sunday, August 8, 2010 8:48 PM
  • Kyle:  I am also having this same exact problem.  I would LOVE to find an answer to our problems for this huge mess!

    Any help is greatly appreciated.

    MommaRip

    Monday, August 9, 2010 1:45 AM
  • Hi sliceanddic3,

    Thank you for your post in MSDN forum!

     

    Some clarification with you

    1, what is your OS?

    2, have you installed Windows XP SP2 on your machine?

     

    If not, you could get it from the following link and install it on your machine.

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=893fd6c0-6283-44c3-bb84-b2f0315b2ae6

    As your error information, I found some errors as follows.

    [08/03/10,20:52:37] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603

    [08/03/10,20:52:53] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.

    The 1603 error code is returned when any action fails during an installation, and most commonly it indicates that

    one of the custom actions in the MSI failed.

    You could refer the following blog. You will get more helpful suggestions.

    http://blogs.msdn.com/b/astebner/archive/2005/08/01/446328.aspx

     

    If it does not work, you could refer your log files to narrow down your issue.

    Or you could send your log files to me. (My E-Mail: v-xugong@microsoft.com)

    Note: Please attach the link of this post in the mail.

     

    Look forward for your good news!

    Best Regards

    Larcolais Gong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, August 9, 2010 9:39 AM
  • Thanks for you're advice! But when I try to install the Windows XP SP 2 on my laptop, another error (as if I needed anymore of those) comes up right as its about to finish and says "amd64\update\update.exe is not a valid Win32 application." I don't know if that is critical to have for .NET 3.5, or if I even have it installed on my laptop. Which I don't think I do. 

    Thanks,

    -Kyle

    Monday, August 9, 2010 5:08 PM
  • Ive Been Trying To Install .Net Framework 3.5 For About 7 Weeks Now,I Have To Have It To Installed To Open Some Programs Im Not Going To Mention What Programs But Back To Framework I Can Install 4.0 Just Fine,No Problems,Thats What I Have Now So It Works Just Fine,But For The Programs They Were Made For 3.5 So I Have To Have It,And Ive Tried To Install It Ive Counted 47 Times,No Exaggeration,I Have The Cleanup Tool I Uninstall All Of It,Why Will it Not Work Please Email Me And Let Me Know (Put Subject As)*.Net* Please So Ill Read It Thanks
    Tuesday, August 10, 2010 2:42 AM
  • Hi sliceanddic3,

    I'm glad to see your reply!

    Could you please download .net framework 3 from Microsoft?

    The following link is:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=10cc340b-f857-4a14-83f5-25634c3bf043&displaylang=en

    You could install .net framework 3 first, then you install .net framework 3.5.

    If you have any issues, you could refer my suggestions.

    Please send log files to my Email.

     

    Look forward for your good news!

    Best Regards

    Larcolais Gong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, August 10, 2010 5:04 AM
  • I've tried to install 3.0 numerous times. The same error, that comes up for 3.5, comes up as its installing. And I'm not that computer savy, so how would I send log files to you're email?

    Thanks,

    -Kyle

    Tuesday, August 10, 2010 6:51 PM
  • Hi sliceanddic3,

    I'm glad to see your reply!

    You could follow my above suggestions one by one.

    Then send the latest log files to my email.

    Look forward for your good news!

    Best Regards

    Larcolais Gong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, August 11, 2010 1:46 AM
  • Hi sliceanddic3,

    I'm writing to follow-up this post. Do the above suggestions help you solve your concerns?

    I'm marking this post as Answered. If you have any findings and concerns, please feel free to unmark this post.

    Best Regards

    Larcolais Gong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, August 13, 2010 3:41 AM