none
Sample Java Applet - Cannot find window RRS feed

  • Question

  •  

    Hi,

     

    I am trying to fire the __GetControlValue__ action against the quick start java applet and am having no joy.  I have cut the control bindings down to a bare minimum, but still no joy.

     

    My init string is:

     

    <?xml version="1.0" encoding="utf-16"?>
    <initstring>
      <homePage>http://sks-ljones-dev2:8081/SwingApplet.html</homePage>
      <adapter>
        <URL>Microsoft.Ccf.HostedApplicationToolkit.AutomationHosting</URL>
        <type>Microsoft.Ccf.HostedApplicationToolkit.AutomationHosting.AutomationAdapter</type>
      </adapter>
      <DataDrivenAdapterBindings>
        <Type>Microsoft.Ccf.HostedApplicationToolkit.DataDrivenAdapter.JavaDataDrivenAdapter, Microsoft.Ccf.HostedApplicationToolkit.DataDrivenAdapter</Type>
        <Controls>
          <JAccControl name="textarea_acc">
            <Path>
              <FindWindow>
                <Class>SunAwtFrame</Class>
              </FindWindow>
              <Next offset="1">Text Area: </Next>
            </Path>
          </JAccControl>
        </Controls>
      </DataDrivenAdapterBindings>
    </initstring>

     

    The applet is starting fine and is hosted properly without the IE security popup bar showing.  When I open the CCFdebugger and fire the __GetControlValue__ I receive the error:

     

    2009-01-20 14:57:43: AutomationAdapter (app=Applet,action=__GetControlValue__): Posted implicit action exception: Microsoft.Ccf.HostedApplicationToolkit.DataDrivenAdapter.DataDrivenAdapterException: DDA0516: Unable to find the window.

     

    I am using the following when firing the action:

     

    Application: Applet (that is the correct name in my config)

    Action Name: __GetControlValue__

    Data: <DdaParameters><ControlName>textarea_acc</ControlName><ControlValue></ControlValue></DdaParameters>

     

    This is effectively what we do programatically under normal circumstances and has worked in the past for other application types under ccf2008

     

    Leon

     

     

     

    Tuesday, January 20, 2009 3:07 PM

Answers

  • This is now resolved.  It was caused by a \n escape character that we picked up when copying the init string and didn't show in the snap-in editor.  It was in the frame name, i.e.  \nSunAwtFrame, so of course was not matched

     

    Wednesday, January 21, 2009 11:34 AM