locked
Localhost does not works RRS feed

  • Question

  • User151466196 posted

    I had installed IIS Ver5.1 on my laptop running on Windows XP Professional Version 2002 Service Pack 2 and when type http://localhost on my IE6, the page can not display.

     Please help.

     

    Thank you.

    Friday, November 17, 2006 11:00 AM

All replies

  • User989702501 posted

    Is IIS running at all ? do you see world wide web service & IIS admin service running?
    If not, try starting it. Then check if IIS is binding at port 80, try 'netstat -an', do you see any x.x.x.x:80 binding?

    Saturday, November 18, 2006 11:51 PM
  • User151466196 posted

    Dear Bernard Cheah,

    Thanks for the info, but I am very new to this and do not understand what you mean.

    How to see if IIS , world wide web service & IIS admin service running? 

    Where to type 'netstat-an'?

    Regards.

    Sunday, November 19, 2006 7:45 AM
  • User989702501 posted

    Oh, Ok.

    a) Checking services status - open administrative tools - services applet, then look at the list and check if those services are running.

     b) Go to command prompt and enter 'netstat -an'

     

    Sunday, November 19, 2006 9:55 PM
  • User151466196 posted

    a) Both services status are 'Started'

    b) I get a whole list but I do not see any of this "x.x.x.x:80 binding".

     

    Thanks.

    Monday, November 20, 2006 2:59 AM
  • User989702501 posted

    Ok, did you change any IIS port binding at the IIS MMC ?
    Go to command prompt, do a 'iisreset'.

    Does it restarts IIS services? then try to browse http://localhost again.
    if not working, what msgs does the browser shows?

    Monday, November 20, 2006 4:03 AM
  • User151466196 posted

    No, I did not change anything after installing IIS, all should be by default.

    After typing 'iisreset', the message shown as follow:-

    Attempting stop...

    Internet services successfully stopped

    Attempting start...

    Internet services successfully started

     With the above, I think it should has restarts.

     

    for <OBJECT id=saOC height=0 width=0 classid=clsid:B45FF030-4447-11D2-85DE-00C04FA35C89></OBJECT>http://localhost , it still does works. The error message I get is as follow:-

    The page cannot be displayed

    There is a problem with the page you are trying to reach and it cannot be displayed.

    Please try the following:

     


    HTTP 500 - Internal server error
    Internet Explorer

     

    Thank you.

     

     

     

    Monday, November 20, 2006 5:16 AM
  • User157784788 posted

     

    In order to fix this or to see if IIS is working fine, try following steps:

    1. Check if Distributed Transcation Co-Ordinator Service is up and running in Services.msc. If Yes then go to step 2 or Step 4.

    2. Create simple time.asp and place in c:\inetpub\wwwroot folder.

    "<%=now()%>" - Copy & paste this code without quotes in a notepad and save the file as Time.asp in c:\inetpub\wwwroot folder - While saving make sure you select Save type as "All Files".

    3.Now browse http://localhost/time.asp instead http://localhost

    4. If above steps does not give expected results then - Go to IIS Manager - Select Default Website > Right click> Properties>Home Directory> Application Protection - Select > Low (IIS Process)

    Click Apply/Ok.

    Now try http://localhost or http://localhost/time.asp

    HTH.

    Thanks!

    Ganesh

    Monday, November 20, 2006 6:13 PM
  • User151466196 posted

    Thanks Ganesh. I am not sute how to check if Distributed Transcation Co-Ordinator Service is up and running in Services.msc? 

    I had tried other .asp file before and they do not work. For htm files, it has no problem running.

    Tuesday, November 21, 2006 1:35 AM
  • User989702501 posted

    For your asp problem. Disable IE friendly error msgs.

    HOW TO: Turn Off the Internet Explorer 5.x and 6.x "Show Friendly HTTP Error Messages" Feature on the Server Side
    http://support.microsoft.com/?id=294807

    post the actual error msgs here. alos take a look at the event viewer, any relevant log entry?

     

    Tuesday, November 21, 2006 2:04 AM
  • User151466196 posted
    Thanks for the link on http://support.microsoft.com/?id=294807 but it is too technical for me to follow.
    Tuesday, November 21, 2006 10:21 AM
  • User157784788 posted

    From that same KB article - Just follow these steps:

    Turn off the friendly error message option in the browser as follows:

    a.  In Internet Explorer 5.x and 6.x, on the Tools menu, click Internet Options.

    b.  On the Advanced tab, under the Browsing section, click to clear the Show friendly HTTP error messages check box, and then click OK.

    c.  Close the browser.

    d. open the browser again and try browsing the other .asp page - if you see error, please post that here.

    Thanks!
    Ganesh

     


     

    Tuesday, November 21, 2006 12:21 PM
  • User151466196 posted

     

    I turned off the friendly error message option in the browser and tried http://localhost/time.asp, error message as follow:-

    Server Application Error

    The server has encountered an error while loading an application during the processing of your request. Please refer to the event log for more detail information. Please contact the server administrator for assistance.

    Thanks.

    Tuesday, November 21, 2006 7:05 PM
  • User989702501 posted
    Now go to - administrative tool - event viewer. Look at application / system event and post related event error here.
    Tuesday, November 21, 2006 9:14 PM
  • User151466196 posted

    There are lot of errors under Application / System, which particular events should I post?

    Also, how to copy these events out?

    Wednesday, November 22, 2006 10:20 AM
  • User989702501 posted

    Oohh. look for the one that is related to IIS Admin, w3svc, etc

    As for copy, open the entry itself. at the dialog box, click copy.

     

    Wednesday, November 22, 2006 11:24 PM
  • User157784788 posted

     

    Did you try this step from my 1st Post:

    4. If above steps does not give expected results then - Go to IIS Manager - Select Default Website > Right click> Properties>Home Directory> Application Protection - Select > Low (IIS Process) - Then browse to Time.asp that you have created

    Problem that you have with IIS is related to IIS Out of Process package in COM+. Check in System event logs for events like Event ID 36 for W3svc, Event id 10004 for DCOM. In event logs - Double click that event and click copy button to copy that entire event information and paste it here.

    HTH.

    Thanks!
    Ganesh

    Thursday, November 23, 2006 6:33 PM
  • User-729904541 posted

      Hi Ganesh,

    I've read this forum and it seems i got a similar problem to this.  When i tried accessing "http://localhost/IISHelp" it doesn't work. (Newly installed IIS 5.1). Here's the error from the event log.

    Source: W3SVC

    Description: "The server failed to load application '/LM/W3SVC/1/Root'.  The error was 'Class not registered"

     

    Anyway, I followed all the steps you've mention above.

     

     Thanks,

    Draco
     

    Wednesday, November 28, 2007 11:34 AM