none
Windbg !deadlock command returns error related to symbols RRS feed

  • Question

  • hi

    I am trying to debug a freeze situation in my driver.  I am trying to run the command !deadlock from Windbg but i am getting the below error

    3: kd> !deadlock
    Error: incorrect symbols for kernel

    I am running a Windows 7 OS SP1 on my host system and a Windows 7 embedded OS SP1 on my target system.

    I have tried speciying the microsoft symbol server path in Windbg. That didn;t help to downlaod the correct symbols.

    I tried running .symfix and .reload commands but that didn't help either.

    Then downloaded the retails symbols package for Windows 7 enterprise SP1 from microsoft and installed those symbols on my  system.  Still i am seeing the same error.

    From where can i get the appropriate symbols for my target OS and how can i resolve this issue?

    Wednesday, September 17, 2014 4:58 PM

All replies

  • have you validated you have correct kernel symbols outside of !deadlock? try breaking in on your driver and dumping the stack and see if the NT symbol names make sense. Run !stacks and see if you get coherent results

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, September 17, 2014 5:19 PM