none
Windbg says "waiting to reconnect" RRS feed

  • Question

  • I am debugging with port number and key, and whenever I try to connect to the target computer for kernel debug, A message box says: Microsoft (R) Windows Debugger Version 10.0.17763.1 AMD64 Copyright (c) Microsoft Corporation. All rights reserved. Using NET for debugging Opened WinSock 2.0 Waiting to reconnect... Nothing else appears. Please help. Debug->break won't work. Firewall is turned off on both host and target machines. There are two adapters for virtualbox, bridged adapter, and NAT. port is 50000 and key is 1.2.3.4.
    • Edited by jguo5258 Wednesday, September 25, 2019 1:24 PM
    Wednesday, September 25, 2019 1:24 PM

All replies

  • Sometimes it helps to watch network traffic, which may give some clue, how/where kernel-debugger (target) announces its 'service':
    Heres a 'message analyzer' snippet of a successful connection:
    DebugTarget -> 169.254.180.228 169.254.246.166 UDP SrcPort: 50001, DstPort: 50001, Length: 382  
    windbg -> 169.254.246.166 169.254.180.228 UDP SrcPort: 50001, DstPort: 50001, Length: 366 
    windbg -> 169.254.246.166 169.254.180.228 UDP SrcPort: 50001, DstPort: 50001, Length: 366 
    windbg -> 169.254.246.166 169.254.180.228 UDP SrcPort: 50001, DstPort: 50001, Length: 366 
    DebugTarget -> 169.254.180.228 169.254.246.166 UDP SrcPort: 50001, DstPort: 50001, Length: 62  

    You can also try connecting with windbg and "target=" argument (FAIK, then windbg tries actively to connect):

    Windbg -k net:port=<yournetworkportnumber>,key=<key_output_from_kdnet>,target=::<IPvAddress>


    With kind regards

    Wednesday, September 25, 2019 2:34 PM