locked
'ASPNEDB.mdf' cannot be opened because it is version 655. This server supports version 612 and earlier. RRS feed

  • Question

  • User-8153698 posted

    Hi,

    I am totally clobbered with this one....

    I have a breand new laptop with only the OS installed.  I have installed VS2008 and its updates I also installed VS2010 and its updates.  I started to recieve the above error when I try to access SQLExpress through the VS interface.

     I deleted both version and all the SQL referances in the Install/Uninstall listing.

    I have reinstalled VS2008 and its updates and I still get this message...

    I find lots or solutions for this error when moving DB's from one machine to another.

    What am I supposed to do?

    Do I delete EVERYTHING (includein the OS) and start from scratch again!

    Friday, November 26, 2010 12:08 PM

Answers

All replies

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, November 26, 2010 12:43 PM
  • User1096912014 posted

    The first blog clearly states

    To fix the problem, go to Tools → Options... → Database Tools → Data Connections and change the SQL Server Instance Name from whatever itwas (probably a SQL Server 2005 instance) to your SQL Server 2008 instance, hit OK and you should be fine!

    Also, perhaps you can uninstall SQL Server 2005 Express if you have SQL Server 2008 installed.

    Friday, November 26, 2010 3:07 PM
  • User-8153698 posted

    Sorry there is no such menu item as DataBaseTool in my Tools-Options page...

    I have completely reformated the HDD and re-installed Windows Windows 7 64bit, from scratch... Added Office 2010, VS2008 and Microsoft  SQL Manager tool and I still get this message....  Sorry but I am so frustrated and none of the solutions seem to fit my situation...

    Any suggestions apart for a GUN!

    Thanks

    I have now restored for the 4th time... Installed just the OS and VS2008... same message

    I then installed VS2010 and got the exact same message from it.

    I have a project due Monday and I still have to test then publish it to the web...

     

    HELP PLEASE SOMEONE????

    Friday, November 26, 2010 5:36 PM
  • User-577741185 posted

    Sorry there is no such menu item as DataBaseTool in my Tools-Options page...

     

    Check the "Show all settings" checkbox at the bottom of the options window.

     

    Saturday, November 27, 2010 7:30 PM
  • User-8153698 posted

    Thanks in my frustration I missed that one completely... 

    Saturday, November 27, 2010 9:35 PM