none
Unable to install ASP.NET web helpers Library RRS feed

  • Question

  • Dear Sir,

    I tried to install ASP.NET web helpers library by clicking "Nuget" ikon in WebMatrix-3 which I stalled recently. I received the following error message:

    An error occurred.

    The schema version of 'Microsoft.AspNet.WebPages' is incompatible with version 2.2.31210.9045 of NuGet. Please upgrade NuGet to the latest version from http://go.microsoft.com/fwlink/?LinkId=213942.

    System.InvalidOperationException: The schema version of 'Microsoft.AspNet.WebPages' is incompatible with version 2.2.31210.9045 of NuGet. Please upgrade NuGet to the latest version from http://go.microsoft.com/fwlink/?LinkId=213942.

    at NuGet.Manifest.CheckSchemaVersion(XDocument document)

    at NuGet.Manifest.ValidateManifestSchema(XDocument document, String schemaNamespace)

    at NuGet.Manifest.ReadFrom(Stream stream, IPropertyProvider propertyProvider)

    at NuGet.LocalPackage.ReadManifest(Stream manifestStream)

    Can anyone give me the correct procedure fro installing web helpers library?

    Thanks,

    Rajagopalan

    Friday, September 25, 2015 2:15 AM

Answers

  • This forum supports setup of the .NET Framework itself.

    As your issue involves web applications, I suggest that you ask in a topical forum here:

    http://forums.asp.net/

    Sunday, September 27, 2015 4:40 PM
  • @Rajagopalan,

    What about manually install the package from this link: https://www.nuget.org/

    As the message says your Nuget package is not compatible with your tool version which caused this error.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, September 28, 2015 1:15 AM
    Moderator

All replies

  • This forum supports setup of the .NET Framework itself.

    As your issue involves web applications, I suggest that you ask in a topical forum here:

    http://forums.asp.net/

    Sunday, September 27, 2015 4:40 PM
  • @Rajagopalan,

    What about manually install the package from this link: https://www.nuget.org/

    As the message says your Nuget package is not compatible with your tool version which caused this error.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, September 28, 2015 1:15 AM
    Moderator