locked
ASP.NET 5 setup fails (0x80072f76) win 10 vs2015 community RRS feed

  • Question

  • User-1415595675 posted

    Hello, 

    I just isntalled vs2015 commnity on a fresh win 10 box to try mvc6 and I noticed after selecting new project > c# > web > asp.net web application, under asp.net 5 templates, there is only "get asp.net 5 rc".  That links to an exe "ASpNet5.ENU.RC1_Update1.exe" which when ran gives me the following: "0x80072f76 - Unspecified error". 

    setup log pasted at http://pastebin.com/G2dtfq7r

    any ideas on how to fix this please? 

    Thanks

    Sunday, December 6, 2015 2:48 PM

All replies

  • User-1415595675 posted

    Hi again, 

    still trying to get the ASP.NET 5 installer to work on a fresh win 10 /vs 2015 install to no avail.  

    Funny thing is, I installed vs2015 community on my overloaded work laptop (old vaio that has 5 different IDEs on it including vs2013, vs2012, vs2010) and the ASP.NET 5 RC1 update 1 installer works fine and I can access the mvc 6 templates through vs2015 community.  

    I am at a loss, thinking that perhaps it's a network issue (but both machines run on same router) and I have disabled IE enhanced security (i remember this being a problem on ms server 2012 instances).

    Monday, December 7, 2015 9:37 AM
  • User-166373564 posted

    Hi,

    al-ma

    there is only "get asp.net 5 rc".  That links to an exe "ASpNet5.ENU.RC1_Update1.exe" which when ran gives me the following: "0x80072f76 - Unspecified error". 

    Please repair Visual Studio 2015 community, and check whether it makes any difference.

    To repair Visual Studio

    1.In Control Panel, on the Programs and Features page, choose the product edition that you want to repair, and then choose Uninstall/Change.

    2.In the Setup wizard, choose Repair, choose Next, and then follow the remaining instructions.

    Regards,

    Angie

    Tuesday, December 8, 2015 9:25 AM
  • User-1415595675 posted

    Hello Angie, 

    thanks for the reply, I have tried your suggestion numerous times... Including uninstalling and re-installing visual studio, with and without web developer tools... In fact I tried installing the full suite but it's always the same problem.  ASP.NET 5 installer hangs and fails with the unspecified error above.  

    I have wasted a lot of hours on this and I am starting to believe there's a serious problem with the OS.  I did a fresh win 7 install (from retail dvd) then manualy upgraded to win 10 (using http://www.microsoft.com/en-us/software-download/windows10) and once windows 10 updates and drivers were installed, I installed visual studio community 2015 and got this problem.  I will do a fresh windows 7 install again tonight without the manual win10 upgrade and see if I get the same issue. 

    Thanks for your time. 

    Tuesday, December 8, 2015 12:07 PM
  • User-166373564 posted

    You can get Visual Studio Community from Microsoft Official site: https://www.visualstudio.com/en-us/products/visual-studio-community-vs.aspx 

    Regards,

    Angie

    Wednesday, December 16, 2015 7:15 AM