locked
SPF & SSRS - Sys.WebForms.PageRequestManagerTimeoutException: The server request timed out. RRS feed

  • Question

  • I''m using SharePoint Foundation 2010 with SQL Server Reporting Services 2008 R2 in integrated mode.  I have a slow running report that times out when being run.  I'm looking at opportunities to tune the report to come back quicker, but because of some decryption being done, this may be difficult to achieve.  So I have a Webpart Page calling an RS rdl report.  I can't seem to find anywhere in SharePoint where you can increase the timeout settings.  There are ones related to time out, but not the issue I am getting.  I've found some mention on the internet about increasing the AsyncPostBackTimeOut setting, but don't know how this is done with a standard webpart page and RS report rdl.

    Below is the error details I am receiving.

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E)
    Timestamp: Fri, 30 Jul 2010 12:44:34 UTC


    Message: Sys.WebForms.PageRequestManagerTimeoutException: The server request timed out.
    Line: 5
    Char: 9936
    Code: 0
    URI: https://sp-server/ScriptResource.axd?d=ZCWeWWD9Ob7K39Gbx89WARncIocIBbyAbdGvXWbA89B7OmtskNMJaV_2N-0VJ53cU-XGhpyfJwxm8JA5Mird_DDN4MK61f2oaYUneArbiD01&t=ffffffffec2d9970

    Friday, July 30, 2010 12:52 PM

Answers

  • Hello bh56,

    I'm posting this link in the hope it will help the situation: http://blogs.msdn.com/b/jgalla/archive/2006/10/11/session-timeout-during-execution.aspx. As for the AsyncPostBackTimeout, it appears to be an ASP.NET parameter related to <asp:ScriptManager>. I'm not sure that's the timeout you're looking for. If so, it's most likely to be found amongst the page code:

          <asp:ScriptManager ID="ScriptManager1" runat="server" AsyncPostBackTimeout="1000">

    You would need to tweak the value of this setting, but, as I said, this may not be the timeout you're looking for. I'm not certain the page this tag would appear on. Please take a look at: http://support.microsoft.com/kb/925083, specifically the section about web.config modifications (you would do this in the web.config for the web site itself in your case):

    Existing code

     <location path="upload.aspx"> 
     <system.web> 
      <httpRuntime maxRequestLength="2097151" /> 
     </system.web> 
     </location> 

    Replacement code

     <location path="upload.aspx"> 
     <system.web> 
      <httpRuntime executionTimeout="999999" maxRequestLength="2097151" /> 
     </system.web> 
     </location> 
    Thanks,
    Tracy
    • Marked as answer by bh56 Thursday, August 12, 2010 5:29 PM
    Thursday, August 5, 2010 9:05 PM

All replies

  • Hello bh56,

    I'm posting this link in the hope it will help the situation: http://blogs.msdn.com/b/jgalla/archive/2006/10/11/session-timeout-during-execution.aspx. As for the AsyncPostBackTimeout, it appears to be an ASP.NET parameter related to <asp:ScriptManager>. I'm not sure that's the timeout you're looking for. If so, it's most likely to be found amongst the page code:

          <asp:ScriptManager ID="ScriptManager1" runat="server" AsyncPostBackTimeout="1000">

    You would need to tweak the value of this setting, but, as I said, this may not be the timeout you're looking for. I'm not certain the page this tag would appear on. Please take a look at: http://support.microsoft.com/kb/925083, specifically the section about web.config modifications (you would do this in the web.config for the web site itself in your case):

    Existing code

     <location path="upload.aspx"> 
     <system.web> 
      <httpRuntime maxRequestLength="2097151" /> 
     </system.web> 
     </location> 

    Replacement code

     <location path="upload.aspx"> 
     <system.web> 
      <httpRuntime executionTimeout="999999" maxRequestLength="2097151" /> 
     </system.web> 
     </location> 
    Thanks,
    Tracy
    • Marked as answer by bh56 Thursday, August 12, 2010 5:29 PM
    Thursday, August 5, 2010 9:05 PM
  • Tracy,

     

    Thanks for your help on this.  Because running in SharePoint Integrated mode, I did have to add this to the web.config in the SharePoint virtual directory for WSS,not the one that Reportserver is using.  But I also needed to bump up the AsyncPostBackTimout as well.

    Thursday, August 12, 2010 5:31 PM
  • Thanks for letting me know the outcome, bh56 -- and I'm glad you sorted this out. <g>

    Thanks,
    Tracy

    Monday, August 16, 2010 4:05 PM
  • Hi. Can you tell me where you changed the AsyncPostBackTimeout?

    Best Regards

    Mario

    Tuesday, July 5, 2011 12:30 PM
  • I am having the same problem. I did implement your suggestion, but it did not resolve the issue.

    Do you have any other solution please.

    Thanks

    amadan@bn.com

    Tuesday, January 10, 2012 9:38 PM
  • Did you try changing timeout in IIS as well?

    IIS

     - Connection Time-Out(seconds)

        - 600

    Saturday, January 14, 2012 3:10 PM