locked
Error 500.19 web config RRS feed

  • Question

  • User1510859543 posted

    We are trying to move a web app from a Windows 2008 server to a Windows 2016 server and we are getting the following error when trying to run the app.  The error appears to be happening on the web.config file in the root of the app. What do I need to do to fix this?

    This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false". 

    Wednesday, January 3, 2018 8:47 PM

Answers

  • User-718146471 posted

    I would recommend you post this over in the IIS Forums because you will get more traction over there and possibly a quicker resolution. http://forums.iis.net

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, January 3, 2018 8:54 PM

All replies

  • User-718146471 posted

    I would recommend you post this over in the IIS Forums because you will get more traction over there and possibly a quicker resolution. http://forums.iis.net

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, January 3, 2018 8:54 PM
  • User753101303 posted

    And this location is really configured as an IIS application root ? Another option is that the IIS configuration of the previous server was altered to unlock configuring some settings at this level. The error message doesn't tell which section it is ?

    Anyway as pointed already it is rather on the IIS side.

    Wednesday, January 3, 2018 9:20 PM
  • User1510859543 posted

    I posted it in the IIS forum.  The error is showing it coming from the web.config file in the application and not the IIS root.

    Wednesday, January 3, 2018 9:26 PM
  • User475983607 posted

    I posted it in the IIS forum.  The error is showing it coming from the web.config file in the application and not the IIS root.

    You're probably still missing server features.  So yes, IIS is the best place for your question.  Or you can post your setup here so we can see what you're doing.

    Wednesday, January 3, 2018 10:24 PM
  • User1510859543 posted

    Another thing I noticed is that when I click on my application in IIS Features View, I do not see a section for ASP.NET Features.  I only see IIS and Management sections.  Does that help with my problem?

    Wednesday, January 3, 2018 11:14 PM
  • User475983607 posted
    Try comparing the 2008 server settings to the 2016 server. Or just Google the error.
    Thursday, January 4, 2018 12:15 AM
  • User283571144 posted

    Hi dlchase,

    I suggest you could firstly check you have already installed all the application development feature.

    • Click "Start button"
    • in the search box, enter "Turn windows features on or off"
    • in the features window, Click: "Internet Information Services"
    • Click: "World Wide Web Services"
    • Click: "Application Development Features"
    • Check (enable) the features. I checked all.

    Image:

    Best Regards,

    Brando

    Thursday, January 4, 2018 6:56 AM