none
related to the receive port uri RRS feed

  • Question

  • Hello All,

    in the receive port uri properties example it has given the syntax "scheme://server[:port]/path/services.svc" so i have configured it as

     "mssql://ssm051[:1433]/databasename/tablename/service.svc"

    so is it right or wrong ? also i didnt understand that what is service.svc. please let me know

    thanking you

    sushil sahu


    sushil sahu
    Wednesday, September 28, 2011 12:39 PM

Answers

  • Hi Sushil,

    It needs to be mssql://ssm051/databasename (for instance mssql://localhost//NorthWind), see for reference my post on WCF-SQL stored-procedure.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server 2010
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly

     


    BizTalk
    Wednesday, September 28, 2011 12:55 PM
    Moderator
  • What type of receive port is this? If this is the SQL Server connection URL check this link .
    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Wednesday, September 28, 2011 12:55 PM
  • Sushil, your uri will be something like this if you are connecting to SQL using WCF-SQL adapter

    Polling:

    mssql://LapServer01/BtsInstance/Northwind?

    TypedPolling

    mssql://LapServer01/BtsInstance/Northwind?InboundId=BizTalkSQ01

    forget about .svc, that is not for SQL uri. Use the above setting as part of your WCF-Custom type and it should work.

    Alternatively, if you install LOB adapter SDK, it will install a nice plugin to your VS from where the binding file would be automatically generated which generates the required port and rec location for you with all the settings.

    Refer this book by Richard which will give you step by step details - http://www.packtpub.com/article/soa-capabilities-in-bizTalk-wcf

    Try this - and report if any issues

    Thanks!


    Prakash Beegala
    Thursday, September 29, 2011 8:22 AM

All replies

  • Hi Sushil,

    It needs to be mssql://ssm051/databasename (for instance mssql://localhost//NorthWind), see for reference my post on WCF-SQL stored-procedure.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server 2010
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly

     


    BizTalk
    Wednesday, September 28, 2011 12:55 PM
    Moderator
  • What type of receive port is this? If this is the SQL Server connection URL check this link .
    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Wednesday, September 28, 2011 12:55 PM
  • wcf custom type

    thanking you

    sushil sahu


    sushil sahu
    Wednesday, September 28, 2011 12:58 PM
  • You are using wcf service so it should be .svc

    http://geekswithblogs.net/BizTalkUnleashed/archive/2010/09/15/configure-biztalk-receive-location-to-accept-any-wcf-messages.aspx


    Thanks, Raja MCTS BizTalk Server 2010 If this answers your question please mark it accordingly
    Wednesday, September 28, 2011 1:44 PM
  • Hello Sushil,

    First you need to understand what you are connecting. Are you connecting to a SQL database through a WCF adapter or connecting to a WCF service? Those are two different things. If it is SQL database through WCF adapter, should be "mssql://server//database?", if it is WCF service, should be "scheme://host[:port]/path/service.svc" or "path/service.svc".

    In your example, you gave a syntax of the combination of both, so it would not work.

    Edmund

    Wednesday, September 28, 2011 2:06 PM
  • Steef is correct because from mssql perfix it seems you want to interact with SQL server. 1433 is default port used by SQL server so you need not to use if you are using default settings for SQL server so the sytax "mssql://<SQLServerInstanaceName>/<DatabaseName>" should work for you.
    Don't forget to mark the post as answer or vote as helpful if it does, Regards -Rohit Sharma (http://rohitbiztalk.blogspot.com)
    Wednesday, September 28, 2011 2:52 PM
    Moderator
  • thank you,

    yes i am connecting to a SQL database through WCF adapter , but when i am configuring the RECEIVE PORT using the WCF-CUSTOM type so below the address(uri) in Example syntax:- it has given the following syntax to write in the uri

    "scheme://server[:port]/path/services.svc" or "/path/services.svc"

    so what should i do ? please let me know..

    thanking you

    sushil sahu


    sushil sahu
    Thursday, September 29, 2011 5:53 AM
  • For SQL Server database connection URI you dont need .svc , did you check the link that I gave in my earlier post. Check this link for SQL Server connection URI.:http://msdn.microsoft.com/en-us/library/dd788089(v=bts.70).aspx
    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Thursday, September 29, 2011 5:57 AM
  • Sushil, your uri will be something like this if you are connecting to SQL using WCF-SQL adapter

    Polling:

    mssql://LapServer01/BtsInstance/Northwind?

    TypedPolling

    mssql://LapServer01/BtsInstance/Northwind?InboundId=BizTalkSQ01

    forget about .svc, that is not for SQL uri. Use the above setting as part of your WCF-Custom type and it should work.

    Alternatively, if you install LOB adapter SDK, it will install a nice plugin to your VS from where the binding file would be automatically generated which generates the required port and rec location for you with all the settings.

    Refer this book by Richard which will give you step by step details - http://www.packtpub.com/article/soa-capabilities-in-bizTalk-wcf

    Try this - and report if any issues

    Thanks!


    Prakash Beegala
    Thursday, September 29, 2011 8:22 AM