none
Game lags when published, but is fine in all testing RRS feed

  • Question

  • I build my games using Game Maker Studio, and when I run tests on UWP within that, the games run as intended. If I export the appx file, and install the game from that, it runs as intended, too. But as soon as it's published to the store, and I download and install it from there, the game has really bad lag and runs really slowly compared to how it should run.

    As I develop in GM:S, I don't have access to a lot of the settings for the game that I guess I would if I used Visual Studio.

    Has anyone else ever had the same issue (either with or without using GM:S) and if so, did anyone fix it? I really want to get my games running as they should.
    • Moved by Breeze Liu Monday, July 10, 2017 6:00 AM publish issue
    Friday, July 7, 2017 9:37 AM

All replies

  • Hi Estragon,

    Since the lagging issue only exists in your Store submission, you could create a support ticket through your developer account so that support can review your specific package.

    Please feel free to post here if you have any update or need further assistance.

    Thank you.

    Best regards,

    Mattew Wu 


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, July 10, 2017 8:55 AM
    Moderator