none
Design view stop working

    Question

  • i have been using VS to develop asp.net application for a little while and it worked fine for me. Today it stop to display design view for aspx files. 

    when i open a .aspx file in source view(my default) it looks fine. i can see tabs of design, split and source at the bottom. when i switch to design view, the display does change and i cannot switch back to source view(i still be able to close aspx file or switch to .aspx.cs file). 

    Please help!

    Thursday, October 06, 2016 6:45 PM

Answers

All replies

  • Hi JieNC,

    Thank you for posting in MSDN forum.

    For this issue, we need to determine the root cause is related to your project or your VS, and please tell us your VS edition.

    Firstly, Please create a new asp.net application. check if the source view in the new one runs normally. 

    If the new application works fine, I doubt that maybe the specific ASP.NET  Project too large impact the VS IDE. So I suggest you load a part of Project under the Solution Explorer check this issue.

    If the issue also occurs on the brand new asp.net application,  I suggest you can try some devenv switches in command prompt check if it can help you.

    a. Run devenv /Safemode to see if you can apply it correctly. This can eliminate the possibility that   third party Add-ins or packages are causing problems.
    b. Run devenv /Resetsettings to eliminate the cause of corrupted settings.
    c. Run devenv /ResetSkipPkgs in Command Prompt.
    d. Run devenv /resetsuerdata

    In addition, I suggest you can try to close the Anti-virus software or the firewall or other tools on your machine or you can try to restart your machine would be better.

    If the above suggestion could not help you, I suggest you could go to Control Panel repair or re-install the your VS check this issue again.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Friday, October 07, 2016 7:29 AM
    Moderator
  • thanks. lana

    i run the visual studio repair. it works. i still don't know what is wrong!


    JieNC

    Monday, October 10, 2016 2:00 PM
  • Hi JieNC,

    There is a possibility that some third party add-ins or extensions affect the VS running normally, or some VS packages missing or corrupted.

    Repair could fix some broken files.

    By the way, if you think my reply is helpful, please mark my reply as the answer, it will benefit other community members who encounter similar issue.

    Have a good day:)

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Tuesday, October 11, 2016 8:21 AM
    Moderator