"WCF-WSHttp" System.TimeoutException RRS feed

  • Question

  • There is a BizTalk Orchestration exposed as a request response service hosted with WCF-WSHttp adapter. Recently we started getting the below error message, this was working with out any issue all along, and no changes were introduced what so ever.


    he adapter "WCF-WSHttp" raised an error message. Details "System.Xml.XmlException: Root element is missing.
       at Microsoft.BizTalk.Adapter.Wcf.Runtime.BizTalkServiceInstance.EndOperation(IAsyncResult result)
       at AsyncInvokeEndEndTwoWayMethod(Object , Object[] , IAsyncResult )
       at System.ServiceModel.Dispatcher.AsyncMethodInvoker.InvokeEnd(Object instance, Object[]& outputs, IAsyncResult result)
       at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeEnd(MessageRpc& rpc)
       at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage7(MessageRpc& rpc)
       at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)".

       The adapter "WCF-WSHttp" raised an error message. Details "System.TimeoutException: The service's security session did not receive 
       a 'close' message from the client within the configured timeout (00:00:10).
       at System.ServiceModel.Security.SecuritySessionServerSettings.ServerSecuritySimplexSessionChannel.OnClose(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Close(TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannel.OnClose(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Close(TimeSpan timeout)
       at System.ServiceModel.Dispatcher.MessageRpc.CloseChannel()".

    A response message sent to adapter "WCF-WSHttp" on receive port "WcfReceivePort_interface.WCF/service1" 
       with URI "/WcfReceivePort_interface.WCF/service1.svc" is suspended. 
     Error details: Root element is missing. 

    Any idea ?


    Mruthunjaya J

    Friday, April 1, 2016 7:20 PM

All replies

  • Hi Mruthunjaya,

    Thank you for posting on MSDN forum.

    The crucial part of the exception is:

    System.Xml.XmlException: Root element is missing.

    This suggests that you are not transmitting what you think you are transmitting.

    From the Suspended Message Instance, check that the message body that being sent is what you expect;


    Change your Send Port Adapter to FILE and write the message out to the file system in order to check the message content.


    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, April 1, 2016 7:27 PM
  • Hi,

    Please check the WCF service deployment in IIS. Ensure that the application pool used for WCF service is using .Net Framework v4.0.30319 and not v2.0.50727.

    Secondly add the following line to the Web.Config of WCF services created and reset the IIS.

              <trust level="Full" originUrl="" />

    Rachit Sikroria (Microsoft Azure MVP)

    Friday, April 1, 2016 7:42 PM
  • Hi Kamlesh Kumar

    I can see that message and i have validated against the expected message, It looks valid. I dont see an issue there.


    Friday, April 1, 2016 7:47 PM
  • Hi Rachit,

    It is already running under the app pool with .Net .Net Framework v4.0.30319.

    Will try by adding 

              <trust level="Full" originUrl="" />


    Friday, April 1, 2016 7:49 PM
  • Even with the below setting, it is still failing with the same error message.
       <trust level="Full" originUrl="" />
    Monday, April 4, 2016 3:08 PM
  • Hi,

    You could also enable diagnostic tracing and message logging, and check whether it can provide more information to troubleshoot.

    Have a good day.



    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Sunday, April 17, 2016 6:36 AM