locked
The IIS Admin Service service terminated with service-specific error %%-2146893818 RRS feed

  • Question

  • User-106520049 posted

    I restarted Exchange 2010 SP2 server after almost 2 years and now IIS Admin service can not start. When i tried to start service it gives me an error

     

    --------------------------- Services --------------------------- Windows could not start the IIS Admin Service on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code -2146893813. --------------------------- OK   ---------------------------

     

    and in Event viewer

     

    Log Name:      System Source:        Service Control Manager Date:          9/22/2013 10:53:38 PM Event ID:      7024 Task Category: None Level:         Error Keywords:      Classic User:          N/A Computer:      ABJSVR28.domain.com Description: The IIS Admin Service service terminated with service-specific error %%-2146893818. Event Xml: <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">   <System>     <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />     <EventID Qualifiers="49152">7024</EventID>     <Version>0</Version>     <Level>2</Level>     <Task>0</Task>     <Opcode>0</Opcode>     <Keywords>0x8080000000000000</Keywords>     <TimeCreated SystemTime="2013-09-22T18:53:38.276485000Z" />     <EventRecordID>762462</EventRecordID>     <Correlation />     <Execution ProcessID="460" ThreadID="6208" />     <Channel>System</Channel>     <Computer>ABJSVR28.domain.com</Computer>     <Security />   </System>   <EventData>     <Data Name="param1">IIS Admin Service</Data>     <Data Name="param2">%%-2146893818</Data>   </EventData> </Event>

     

    I tried following but still no success.

     

    1. rename MetaBase.xml and restore newest and oldest file from C:\Windows\System32\inetsrv\History to C:\Windows\System32\inetsrv

    2. Verified C23* key GUID agaist registry and its matched, the key which is after "_"

    3. Verified System and Administrator security permission on C23* machine key as well as MachineKey folder from C:\Users\all users\Microsoft\Crypto\RSA\MachineKeys

    4. Rename machinekeys folder and restart server to generate new folder with same key but didnt work.

    I followed all above steps without any success.

     

     

    Now my final hope is from you techies. Please let me know possible resolution except reinstalling IIS 7 and Exchange 2010.

     

    OS: Windows Server 2008 R2 SP1 Standard Edition

    Application: Exchange 2010 SP2

    Sunday, September 22, 2013 3:04 PM

Answers

  • User1030553310 posted

    Hi shahvikask,

    Please try to refer to the following solution:

    1. Check in C:\Windows\System32\Inetsrv\History, you should have a backup of Metabase.XML & MBSchema.XML. Backup the existing Metabase.xml and MBSchema.xml from C:\Windows\System32\Inetsrv.

               Rename the backup from the 'History' folder. Copy & Paste each of these to the C:\Windows\System32\Inetsrv.  Then run iisreset.

    2. To completely remove and reinstall the IIS Server Role and all of its depended components.

    Hope it can help you.

    Best Regards,
    Terry Guo

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, September 24, 2013 7:25 AM