none
SSRS authentication to a data source in another domain without trust RRS feed

  • Question

  • A client is asking to create an SSRS report (SharePoint-integrated) which pulls data from a SQL database in another domain.  There is no trust between the SharePoint domain and the SQL data source domain.  SharePoint is running on SQL 2014; data source SQL version is 2008.

    What is the best way to set up SSRS report authentication in this scenario?


    Andre Galitsky, MCTS, Richmond, VA -- My SharePoint Blog: http://sharepointnomad.wordpress.com

    Saturday, June 10, 2017 4:08 PM

All replies

  • Hi Andre Galitsky,

    If the report retrieves data from a remote server database, we can use the SQL Server Authentication. 

    At the same time, you need to verify the following:

    • The SQL Server Authentication Account is correct and has the appropriate permission
    • Ports used by the database server are open. If you are accessing SQL Server relational databases on external computers, or if the report server database is on an external SQL Server instance, you must open port 1433 and 1434 on the external computer. Be sure to restart the server after you open ports.
    • Remote connections must be enabled. If you are accessing SQL Server relational databases on external computers, you can use SQL Server Configuration Manager tool to verify that remote connections over TCP are enabled.

    Reference: Specify Credential and Connection Information for Report Data Sources

                     Configure a Report Server Database Connection (SSRS Configuration Manager)

    If you have any questions, please feel free to ask.

    Best Regards,

    Henry 

    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Henry Jiang Tuesday, June 13, 2017 9:39 AM
    Monday, June 12, 2017 6:22 AM