none
Data Factory Linked Service for Dynamics CRM 365 won't connect

    Question

  • Hi,

    When I create a sink (target) using Dynamics 365 Linked Service in Data Factory Version 2, it won't connect & gives error:

    [{"code":10013,"message":"Unable to Login to Dynamics CRM"}]

    I set the following parameters:

    Connect via integration runtime = Default
    Deployment Type = Online
    Service Uri = https://datatest01.crm11.dynamics.com
    Authentication type = Office365
    User name = simon@datatest01.onmicrosoft.com


    I am confident I have the correct CRM service Uri from my trial instance and my user is active and I can login with that username and password.

    Is this a known bug?

    Friday, May 11, 2018 8:47 AM

All replies

  • Have you already tried the documentation here? if not, can you please try to recreate your connection using the document and if the error still persists, please let us know.
    Friday, May 11, 2018 7:47 PM
    Moderator
  • I'm seeing this error as well after following the linked documentation and using settings similar to sp_harris

    [{"code":10013,"message":"Unable to Login to Dynamics CRM"}]

    Saturday, May 12, 2018 1:10 AM
  • Hi,

    I have followed the documentation, but still can't get the CRM connector to work - please advise. 

    Monday, May 14, 2018 8:12 AM
  • I tried to open your service endpoint in a browser, but it says:

    "Organization Id Not Determined. Error. The current Organization ID couldn't be determined".

    Could you please check whether it's correct?

    Meanwhile, could you please verify your information works. There are several tools provided by Dynamics team which can serve this purpose, for example: CRM Data Migration Tool:

    Please make sure you can login successfully using this tool, then use the same set of information to input ADF linked service.https://community.dynamics.com/enterprise/b/dynamics365enterprisecloudfronts/archive/2017/04/25/crm-data-migration-tool

    Monday, May 21, 2018 2:17 AM
  • Hi,

    I tried using the Data Migration Utility, however that failed to connect or find the CRM instance as well.

    Regards, Simon.

    Monday, May 21, 2018 12:14 PM
  • Are you sure this is a correct service url? Do you have multiple organization associated with this service?

    Tuesday, May 22, 2018 4:49 AM
  • Hi,

    The CRM instance is a trial, I created and haven't changed anything or added anything - I just wanted to understand how Data Factory could load data to CRM.

    When I look in the CRM instance there is only 1 business unit datatest01.

    Regarding 'correct service URL' - I can follow the link: https://datatest01.crm11.dynamics.com and login with Username = simon@datatest01.onmicrosoft.com - let me know if you want the password?

    If I should be using a different url for Datafactory connection then please let me know?

    Looking in Developer Resources I can see:

    Discovery Web API    - https://disco.crm11.dynamics.com/api/discovery/v9.0/
    Instance Web API     - https://datatest01.api.crm11.dynamics.com/api/data/v9.0/
    Organization Service - https://datatest01.api.crm11.dynamics.com/XRMServices/2011/Organization.svc
    Discovery Service    - https://disco.crm11.dynamics.com/XRMServices/2011/Discovery.svc

    Please advise which URL DataFactory Dynamics 365 connector is expecting?

    Regards, Simon.

    Tuesday, May 22, 2018 8:13 AM
  • Hi Simon, 

    Could you please send an email to me (chuncw@microsoft.com) with all the details of your trial instance? Let's take this offline and look into it further there, then come back with a solution for the community. 

    Thanks.

    Wednesday, May 23, 2018 3:01 AM
  • We figured it out that the root cause is that crm11 (United Kingdom) instances are not supported by ADF yet. We will catch up and let the community know once it's available. 
    Wednesday, May 23, 2018 1:16 PM
  • Did the problem with crm11 was resolved?
    Wednesday, June 20, 2018 7:15 AM
  • Not yet, it's in our backlog. Please submit your request here: https://feedback.azure.com/forums/270578-data-factory. And we will reprioritize.
    Wednesday, June 20, 2018 12:24 PM
  • Is there any work around? 

    Monday, July 16, 2018 10:06 AM
  • Is there any progress/work around with crm 11?

    Wednesday, September 12, 2018 5:23 AM
  • We are working on it recently. Should be supported before long.
    Friday, September 14, 2018 3:06 AM
  • Dynamics crm11 is supported in ADF v2 now.
    Monday, October 15, 2018 6:13 AM