Adding WebPart from Main Site to Sub Site - Error opening Docs


  • Hello,

    I have a particular document library that I want to add as a web part on a sub-site in SharePoint. I went through the steps of opening the site in SharePoint Designer > exporting the web part to a file/gallery > and uploading the web part as a custom web part on the sub-site.

    Now this WORKS, I can see the web part on the sub site. But everytime I go to open one of my Word Documents I receive this error. PDF's work with NO PROBLEM. This only occurs to Word Documents. Any thoughts on this??

    Sunday, January 26, 2014 4:37 PM


  • It is a free version but it has limitations. I think it restricts movement to within the same web/site collection.

    I'd always suggest caution when playing with CodePlex stuff, so it might be worth downloading it and having a play in a test area.

    Steven Andrews
    SharePoint Business Analyst: LiveNation Entertainment
    Twitter: Follow @backpackerd00d
    My Wiki Articles: CodePlex Corner Series
    Please remember to mark your question as "answered" if this solves (or helps) your problem.

    Monday, January 27, 2014 9:47 AM
  • There is also the OOTB method in the first link that I posted where you essentially use web services to connect to the other list.

    Dimitri Ayrapetov (MCSE: SharePoint)

    Monday, January 27, 2014 1:25 PM
  • Another OOTB option is the content query webpart. The content query webpart is more efficient than dataviews and you won't have to use SharePoint Designer which is a bonus.

    Information on the CQWP here.

    Monday, January 27, 2014 1:48 PM

All replies