none
how to get system.directoryservices.dll to version no 2.0.50727.4927 RRS feed

  • Question

  • Hi i have vista machine which has .net framework 2.0, 3.5, 3.5sp1, 4.0 installed and version no for system.directoryservices.dll is 2.0.50727.3053. i have another windows server r2 machine which has .net framework 2.0 and 3.5 installed on it and system.directoryservices.dll version is 2.0.50727.4927. could anyone tell me how to upgrade my vista dll to 2.0.50727.4927. i am surprised because i have all possible installation on vista but version is lower thn my r2 machine. i want this because we need to access addtional code defined in later version.
    Thursday, July 29, 2010 1:22 PM

Answers

  • Hi rohit,

    Thank you for your post in MSDN forum!

    Sorry for the late reply!

     

    Some clarification with you

    1, when did your occur?

    2, if you have any error information, could you please provide kindly more information?

     

    As I know, the version of 2.0.50727.3053 is installed with .net framework 3.5 sp1.

    The version of 2.0.50727.4972 is installed with Windows 7 RTM.

    Based on your description, your machine is installed .net framework 3.5 SP1.

    More information about framework version, you could refer the following link.

    http://en.wikipedia.org/wiki/List_of_.NET_Framework_versions

    Frankly speaking, you could upgrade your vista machine firstly via Windows Update.

     

    If you have any specific issue and concern, you could attach it in your reply.

    More details could help me solve your issues exactly.

     

    Look forward for your reply!

     

    Hope this helps you! If you have any doubts and concerns, please feel free to let me know. We are going to continue to follow-up.

    Best Regards

    Larcolais Gong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, August 2, 2010 2:09 AM

All replies

  • Hi rohit,

    Thank you for your post in MSDN forum!

    Sorry for the late reply!

     

    Some clarification with you

    1, when did your occur?

    2, if you have any error information, could you please provide kindly more information?

     

    As I know, the version of 2.0.50727.3053 is installed with .net framework 3.5 sp1.

    The version of 2.0.50727.4972 is installed with Windows 7 RTM.

    Based on your description, your machine is installed .net framework 3.5 SP1.

    More information about framework version, you could refer the following link.

    http://en.wikipedia.org/wiki/List_of_.NET_Framework_versions

    Frankly speaking, you could upgrade your vista machine firstly via Windows Update.

     

    If you have any specific issue and concern, you could attach it in your reply.

    More details could help me solve your issues exactly.

     

    Look forward for your reply!

     

    Hope this helps you! If you have any doubts and concerns, please feel free to let me know. We are going to continue to follow-up.

    Best Regards

    Larcolais Gong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, August 2, 2010 2:09 AM
  • Hi,

     

    We are getting error when framework  method System.DirectoryServices.ActiveDirectory.getCurrentDomain is called through code. Error description is

     

    System.DirectoryServices.ActiveDirectory.ActiveDirectoryOperationException: The requested mode is invalid.
      at System.DirectoryServices.ActiveDirectory.Domain.GetDomainMode()
      at System.DirectoryServices.ActiveDirectory.Domain.get_DomainMode()
      at ActiveDirectoryServiceLayer.GetFunctionalDomainLevel()”

     

    Operating System in use is Windows Server 2008 R2.

    When we  Looked into GetDomainMode method through reflector it seems that there is no domain mode for Windows Server 2008 R2 defined in method, Enumeration DomainMode has following values

    public enum DomainMode
    {
        Windows2000MixedDomain,
        Windows2000NativeDomain,
        Windows2003InterimDomain,
        Windows2003Domain,
        Windows2008Domain
    }

     It is clear that there is no value for Windows2008R2Domain in enumeration and getDomainMode() method.

    Details of environment are as below.

    ·         Version for  System.DirectoryServices.dll is 2.0.50727.4016.

    ·         Operating System is Windows Server 2008 R2.

     

    It would be highly appreciated if you could tell us which version of .net framework\patch\hot fix would update our version to right version so that it could return domain mode to windows server 2008 R2

    When this operating system is in use.

     

    Monday, August 2, 2010 7:56 AM
  • Hi rohit,
    I’m glad to see your reply!
    Sorry for the late reply!

    Some clarification with you

    On my previous reply, 2.0.50727.4927 is installed with Windows 7 RTM.
    As I know, this framework’s version might be installed with Windows 7 RTM.
    Windows 7 is including .net framework 2 SP2, which might be including some later packages.
    You could attempt to update .net framework 3.5 SP1.
    The following link talk about this issue.
    http://support.microsoft.com/kb/959209
    Frankly speaking, it seems that your issue is caused by version of OS.

    Hope this helps you!
    Best Regards
    Larcolais Gong
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, August 5, 2010 5:58 AM
  • Hi rohit_uk,

    I'm writing to follow-up this post. Do the above suggestions help you solve your concerns?

    I'm marking this post as Answered. If you have any findings and concerns, please feel free to unmark this post.

     

    Best Regards

    Larcolais Gong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, August 9, 2010 2:31 AM