none
Blank AS2 MDNs (both synchronous and asynchronous) RRS feed

  • Question

  • I have set up a synchronous MDN AS2 agreement with a third party with whom we are exchanging EDI document (AS2 send \receive pipelines).

    On the receive side , I am having a problem in sending back asynchronous MDN. Through wireshark I monitored that BizTalk is sending back a blank MDN which doesn’t have AS2 headers and hence the partner gets an error that the delivery of their message failed whereas on our BizTalk server, we receive the document successfully and no error is generated. The message exchange sequence when client sends us message as captured via Wireshark is given below .

    POST /WOW/BTSHTTPReceive.dll HTTP/1.0
    Host: as2uat.costagroup.com.au:75
    User-Agent: RPT-HTTPClient/0.3-3I (Linux)
    AS2-From: GXS_AS2_ICS
    AS2-To: COSTAAS2UAT
    AS2-Version: 1.2
    Date: Fri, 24 Jul 2015 05:26:18 GMT
    Disposition-Notification-Options: signed-receipt-protocol=optional,pkcs7-signature; signed-receipt-micalg=optional,sha1
    Disposition-Notification-To: http://as2.am.gxsics.com/enterprise/as2
    EDIINT-Features: AS2-Reliability
    From: notifyas2@gxs.com
    Message-ID: <003646685903804443@as2.am.gxsics.com>
    Mime-Version: 1.0
    Subject: AS2 Data Message Request
    Accept-Encoding: deflate, gzip, x-gzip, compress, x-compress
    Content-Type: application/pkcs7-mime; smime-type=enveloped-data
    Content-Length: 3392

    0...*.H..
    .....0....1..0.....0@021.0..
    ..&...,d....costas1.0...U....Costa Group UAT.
    a.2.......0
    ..*.H..
    ...........!..I....%c..e..A..Qj......>._..o.3...]g].|....mE......h....f......K%.a......d.?..eRVN9.N?w.......[f .f,..j..T.J.)c8..+.J....A0...*.H..
    ...0...*.H..
    ..........7"......r...cvz.\
    .}...I.....=+....-..j.L.9u....PiG.d.AkN"...;t.jmZd..voa.....2E......h.6....c......N..=.J=.,.5..:.K..[.........5......<z.6.:_D7?...}XFED.a....t.t.I...,W..S.2.tJ.</....Gc.B......!1...L.e...P..._2t.....*>.....K"..O.P...<..'M.3F ......??
    ...kv.@m.\O....j.+a...;_.HT..........g..e...<..[$&D..'Fs...f,..yw.......M.W.DS%..c.......z
    <.SZM8T..)uf..[J...7.Z|.s..q[5.....b.2......V..n.n..}.>.AH........^.....5J8?.._O..u"g:....Z
    ...)v....w..y..>.........pB.......VEj....#w.4{.s.../......h%...#g
    |..\.c..[.,.;...F...6....:.....
    .;.\1<lQn.....'d.]..c..(.c`..Z...{.w.....z..(..........Z...v.../_.X.CH...I......9....d.H0"Xe..XN6.....?.k69.......U=.
    `.....ac....k..K...-.Z.?.]].k.'..{...~...U.N....Q....d..........B...wc...)....*.....Py....m.....x..
    d.....<...{/D.3\.1w:VG...E...W. ..... 
    ..'b...)k\......r......._.)...lkt......n...z.kJ.r_,`...nW......... .H.JEDC......%._....,G.........d....\....P\.
    ?$..4vK..e.S.l..u.....j.uM....,....g....:...b.S..*...%.q..d.."..:.;.....,Mo.d..bhZS..5>...
    ..%...B|.<....cL.FuS..p.ZJ...... .]...d.w...Np....8...v8.....6...X.....\..@:.l.|.}.^K..~.."...3....,...a.~...K.....).rA....-.U.@.]v.....a..2...n......:.P.G..D.#.O!JX...f..S.......i6M.d../I........[...n....bCA......_c...<...)E....x..3.0..1Bme.8e.{..s...1...a...ntDE9u.8N0..(.......)........6...j...h
    .6...&......5...zG....1K..C8.ub3.Y.U7T.Y...E6;k.U..H5.].@]...L.n..+|..-...Tr..+a.;K..... ...T..}C..."Ep....9...G.E.......\...R.Njspm..g...E*B...N4....;...Z.3..:...G=.........h&&*./...!wp...:.....Z....U.'....,-H......#....9P...0....8.&.%.=...~.....A.\Y..#..x..h..$.#f...~;..V..
    ........<.Z.c.>..... ./..}.N.6e,U....p..y.R5]f.P!K6..X 0.... .....#..g...-Mp........@.
    ...o.....i.
    `..vx.gR.......Zt.....+........c.."c.F..........^..[/.......I.L.9..Ss..~..p.Q..C......n2.k|e.f..|...r..8.....'....x.?.........VZ...h.e.y.>...OI.b..8.}6E.
    ?...#A.s....)..K...h..?zR;.5.......K............uIc.a..lh.R..Z..;...f...k.pf[<...3obE...O-............4....E..|*.L.\[+...+.^...KM...oX........R..B..U\..1.).SW..S....Rh.0C.......I............-L....7.`L+)C......J..g.\z..e/.....]..|..>......W...-sqBPpo.N...^@....q.>.....5.D0,.,( ..1.(s....'..a\...~.f.i.o..).WM^...U(g.{..#.{.Vm.......|....@.l%.2_d.?$.........)..L+).'.p.:...|.vg..B.w).w.k".^..Y......f.)#..x/Z.i...H)....=|.].....
    0m?F...t$#.e...",..e.f..
    .$..G...v..zr.... J.~..N..l.R..z.....DC.~b......>\..`
    .....g.>.{J.x.....2....h........1.z..VD..uA2
    .k........o=..8.j.v..
    ..].W.][.0..i...v...h.s.;....4.....A...b.=..(....^....4.F`.P>.-/.'.J...s..x.....oL..:....q.h.Z..!.
    1...z|..?.AS.+....tt..>.....k.......i..d...T.AzH.H..c.........x."]..|`..N2.f.[.d..!...2....e....;vw.......Fy.<../....}...C:"..Y..*..x.Z....A..&............fy...V..\[..D..;.......W...<[<.G.X..>.D .`..Q@+.*&.J.. .`.+.t.......K,.....H....$...
    =0M'.....{.!...u...U%....q.0.....D.O.leJ$...^#Q..1...2%{..Adv.Q"..pm.P.7&#...?md3..........gv
    V...wgUv..?$..Vk=t.u/...1.U.....#.n...b...6..#:...2..|.i.".^V.5.....l..N....R..r.{Y.U........c4.s....P}.-#.t.G.Fr....
    ..|.(....M.MB.........7.E..i.N...Ip..M.}e.C'.%.w/.8.B...S.j..GH......Q.\.8.......&...q%<....#."....H9i.X........p..........[.s.
    C.P.4..Rf.S..w.<...8...&..a...%............

    HTTP/1.1 200 OK
    Content-Length: 0
    Content-Type: application/edifact
    Server: Microsoft-IIS/7.5
    X-Powered-By: ASP.NET
    Date: Fri, 24 Jul 2015 05:26:28 GMT
    Connection: close

    <o:p></o:p>

     <o:p></o:p>

    In BizTalk admin AS2/MDN  status report, the status of MDN is set to “Acknowledged-Processed” but it appears under Acknowledgement-Rejected filter (because of blank AS2 header).

    The HTTP settings for message reception on AS2 Agreement have three options true : Expect 100 continue, Unfold Http headers, keep connection alive

    The HTTP settings for MDN on AS2 Agreement have no options selected.

    AS2 IDs are correct 

    Monday, July 27, 2015 8:11 PM

All replies

  • Hi Faizaaustralia,

    Please check certificate configured correctly because if the wrong certificate details are configure for an AS2 party, your partner cannot decode/decrypt the message and it might look blank. Please make sure your partner has all the certificate details.

    Please refer below related thread for reference,

    AS2 Synchronus Empty MDN


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Sunday, August 30, 2015 8:36 PM