locked
Access Provider not found Oledb Jet 4.0 RRS feed

  • Question

  • User363754837 posted

    I created an asp form that connect to my access database, uding windows server 2003 64X but i am having trouble accessing the page due to the error that says provider not installed on local machine,

    i found some posts online that requested to make the iis allow 32Bit connection which i did; however the error now is gone but the page keep looping without displaying anything.

    I hope that i explained my problem clearly if anyone have the answer to this please share it with me.

    Thanks 

    Thursday, April 22, 2010 7:39 AM

Answers

  • User913369412 posted

    I had the same problem, and just fixed it.

    I'm running Windows 7 x64 with IIS 7.5 and ASP.NET v3.5

    After noticing that the project would work correctly if I started the website from a file location instead through IIS, turns out IIS wasnt allowing the website to run in 32-bit mode, and all I had to do was change the Application Pool's Advanced Setting: Enable 32-bit Applications to true for the app pool my site was running (which for me was the DefaultAppPool). Didn't even need to rerun the aspnet_regiis -i option.

    See link for reference: http://stackoverflow.com/questions/1201918/the-microsoft-jet-oledb-4-0-provider-is-not-registered-on-the-local-machine

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, April 30, 2010 6:47 PM

All replies

  • User-740453238 posted

    Can you post your that we can verify that you are connection properly. 

    Thursday, April 22, 2010 8:59 AM
  • User363754837 posted

    Unable to find the requested .Net Framework Data Provider.  It may not be installed.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentException: Unable to find the requested .Net Framework Data Provider.  It may not be installed.

    Source Error:

     

    Hope this explains everything

    Thursday, April 22, 2010 12:28 PM
  • User363754837 posted

    Unfortunately i had these links already but did not yield any good results i am still in search of the right answer thanks for your reply.

     

    Thursday, April 22, 2010 1:50 PM
  • User913369412 posted

    I had the same problem, and just fixed it.

    I'm running Windows 7 x64 with IIS 7.5 and ASP.NET v3.5

    After noticing that the project would work correctly if I started the website from a file location instead through IIS, turns out IIS wasnt allowing the website to run in 32-bit mode, and all I had to do was change the Application Pool's Advanced Setting: Enable 32-bit Applications to true for the app pool my site was running (which for me was the DefaultAppPool). Didn't even need to rerun the aspnet_regiis -i option.

    See link for reference: http://stackoverflow.com/questions/1201918/the-microsoft-jet-oledb-4-0-provider-is-not-registered-on-the-local-machine

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, April 30, 2010 6:47 PM