enable cors with windows authentication mode RRS feed

  • Question

  • User-1201003476 posted

    getting 401 message when consumed aspx with post method  .Cors and windows authentication enabled

    <?xml version="1.0"?>
        <cors enabled="true">
          <add origin="*" allowCredentials="true" />
        <identity impersonate="true"/>
        <authentication mode="Windows"></authentication>
    Wednesday, August 26, 2020 3:09 PM

All replies

  • User-848649084 posted


    Could you please share which cors verb you are trying? you could try to use the below configuration setting to resolve the issue.

          <add name="aspNetCore" path="*" verb="*" modules="AspNetCoreModule"
                      resourceType="Unspecified" />
        <aspNetCore processPath="dotnet" arguments=".\WebApiEcho.dll"
                      stdoutLogEnabled="false" stdoutLogFile=".\logs\stdout" />
                    <anonymousAuthentication enabled="true" />
                    <windowsAuthentication enabled="true" />
                    <remove users="*" roles="" verbs="" />
                    <add accessType="Allow" users="?" verbs="OPTIONS" />
                    <add accessType="Allow" users="" roles="USERS" />


    Thursday, August 27, 2020 6:31 AM