none
Disable Initial Logon Windows Update Prompt RRS feed

  • Question

  •   I'm preconfiguring Windows Update in the registry during audit mode in setup.  How do I disable the windows update configuration that oobe displays as part of the initial logon?

     

    Thanks

     

    • Moved by Lynda Allen - MS Tuesday, December 14, 2010 1:37 AM Relates to Standard 7 (From:Standard 2009: Components/Run-time Issues)
    Tuesday, November 23, 2010 4:43 AM

All replies

  • Is this on Windows Embedded Standard 2009 or Standard 7?
    Tuesday, December 14, 2010 1:24 AM
  • This is for Embedded Standard 7.   FYI Shell-Setup->OOBE->ProtectYourPC is set to "2".   The documentation falsely says "If a value is not set, the Help protect your computer and improve Windows automatically page opens during Windows Welcome."   Anyone with the smallest knowledge of English syntax reads that to mean if you set a value, the page to setup windows update will not appear.
    Tuesday, December 14, 2010 1:35 AM
  • This setting can only be setup for Pass 7 OOBE. You are correct, if the value is set to either 1, 2, or 3, then the protect PC OOBE screen will not appear.

    Are you saying that you are seeing the screen even though you have this setup in the answer file?
    -Sean


    www.sjjmicro.com / www.seanliming.com, Book Author - XP Embedded Advanced, XPe Supplemental Toolkit, WEPOS / POS for .NET Step-by-Step
    Tuesday, December 14, 2010 2:19 AM
    Moderator
  • That's exactly what I'm saying, I set ProtectMyPc to 2 and the screen still appears.   Have you actually tried this?
    Tuesday, December 14, 2010 3:13 AM
  • I have set the value to 1 and 3 and have not seen the screen appear. Are you seeing the screen through the first installation or through a second boot when doing an audit?

    -Sean

     


    www.sjjmicro.com / www.seanliming.com, Book Author - XP Embedded Advanced, XPe Supplemental Toolkit, WEPOS / POS for .NET Step-by-Step
    Tuesday, December 14, 2010 3:22 AM
    Moderator
  • I'm seeing the screen on the first oobe boot after I shutdown from audit
    Tuesday, December 14, 2010 3:23 AM
  • OK. Did you create an unattended.xml file for sysprep? If so is the parameter in the file?

    -Sean

     


    www.sjjmicro.com / www.seanliming.com, Book Author - XP Embedded Advanced, XPe Supplemental Toolkit, WEPOS / POS for .NET Step-by-Step
    Tuesday, December 14, 2010 4:38 AM
    Moderator
  •  <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <ProtectYourPC>2</ProtectYourPC>
                    <HideEULAPage>true</HideEULAPage>
                </OOBE>
            </component>
    Tuesday, December 14, 2010 5:23 AM
  • Ok. Did you run sysprep again when exiting audit mode?

    -Sean

     


    www.sjjmicro.com / www.seanliming.com, Book Author - XP Embedded Advanced, XPe Supplemental Toolkit, WEPOS / POS for .NET Step-by-Step
    Tuesday, December 14, 2010 9:13 PM
    Moderator
  • I sure do.  In fact, its pretty much impossible to go from audit to oobe without using sysprep

    Tuesday, December 14, 2010 9:15 PM
  • Interesting. Not sure what to say other than try a different value, but I don't think that is going to help. Sounds like a bug that needs to be filed.

    -Sean

     


    www.sjjmicro.com / www.seanliming.com, Book Author - XP Embedded Advanced, XPe Supplemental Toolkit, WEPOS / POS for .NET Step-by-Step
    Wednesday, December 15, 2010 2:11 AM
    Moderator
  •    I found a fix to my problem.  When I specify a ProtectMyPc in the autounattend.xml that I use to select the system components, after shutting down to oobe generalize, the setting disappear.  When I add copy a special unattend.xml  into system32\sysprep, it processes the ProtectMyPc setting and hide the selection box.

     

    Tuesday, January 11, 2011 2:21 AM