locked
AspMaxRequestEntityAllowed RRS feed

  • Question

  • User-1962508071 posted

     Please could someone tell me how to change the AspMaxRequestEntityAllowed setting in IIS7. In IIS6 it was done by editing the metabase.xml file. I need to change this setting in IIS7 manually not through an application.

    Thanks. 

    Saturday, July 7, 2007 7:49 PM

Answers

  • User989702501 posted

    Go to the IIS Manager, navigate to the site, then click on 'asp' icon. in the limit property setting, change it to the value you want.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, July 9, 2007 12:16 AM
  • User113421904 posted

    Hi,

    It is now maxRequestEntityAllowed in IIS 7.0, you can also change it with appcmd:

    appcmd set config /section:asp /maxRequestEntityAllowed:int

    The variable int represents the maximum number of bytes allowed in the entire body of an ASP request. The default value is 200000 bytes.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, July 9, 2007 1:50 AM

All replies

  • User989702501 posted

    Go to the IIS Manager, navigate to the site, then click on 'asp' icon. in the limit property setting, change it to the value you want.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, July 9, 2007 12:16 AM
  • User-1962508071 posted
    So easy when you know how! thanks.
    Monday, July 9, 2007 12:39 AM
  • User113421904 posted

    Hi,

    It is now maxRequestEntityAllowed in IIS 7.0, you can also change it with appcmd:

    appcmd set config /section:asp /maxRequestEntityAllowed:int

    The variable int represents the maximum number of bytes allowed in the entire body of an ASP request. The default value is 200000 bytes.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, July 9, 2007 1:50 AM
  • User-174939589 posted

    hi

    can someone help:

    C:\Windows\System32\inetsrv>appcmd set config /section:asp /maxRequestEntityAllowed:300000
    ERROR ( message:Unknown attribute "maxRequestEntityAllowed".  Replace with -? for help. )

    Tuesday, March 17, 2009 2:57 PM
  • User989702501 posted

    Mmm.. the attribute name is maxRequestEntityAllowed
    http://www.iis.net/ConfigReference/system.webServer/asp/limits

    so it should be valid. can you just replace it with -? to see what you see?
    I don't have my vista with me, so do a appcmd list config /section:asp
    you should see all attributes in this section.

     

    Wednesday, March 18, 2009 4:27 AM
  • User1553076391 posted
    appcmd set config -section:asp -limits.maxRequestEntityAllowed:300000
    Friday, May 14, 2010 12:27 PM