none
Installing .NET Framework 4.6.2 RRS feed

  • Question

  • Hello !

    I've encountered an issue trying to install .NET Framework 4.6.2 . After I open the application(setup) it shows me an error "The .NET Framework 4.6.2 is not supported on this operating system."

    Hope I can find some help.


    Friday, July 28, 2017 4:08 PM

Answers

  • Hi,

    Welcome to MSDN forum.

    >>The .NET Framework 4.5.x/4.6.x/4.7 is not supported on this operating system.

    For failed installations of the .NET Framework on Windows 7, this message  typically indicates that Windows 7 SP1 is not installed. On Windows 7 systems, the .NET Framework requires Windows 7 SP1. If you are on Windows 7 and have not yet installed Service Pack 1, you will need to do so before installing the .NET Framework. For information on installing Windows 7 SP1, see Learn how to install Windows 7 Service Pack 1 (SP1).

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, July 31, 2017 5:31 AM
  • If System property doesn't show "Service Pack 1", Service Pack 1 is not installed in Windows 7. I suppose it causes this .Net Framework issue. 
    Try to install/update Service Pack 1.

    You can download SP1(KB976932) via Microsoft Update Catalog:
    https://www.catalog.update.microsoft.com/Search.aspx?q=KB976932
    (Please select one according to your Window 7: 64bit/32-bit)
     

    Ashidacchi


    Monday, July 31, 2017 5:47 AM

All replies

  • ".NET Framework 4.6.2" supports Windows 10, 8.1, and 7.
        Please refer to the following page:
        .NET Framework Versions and Dependencies
        https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/versions-and-dependencies

    Which Windows are you using?

    Ashidacchi

    Saturday, July 29, 2017 12:07 AM
  • I use Windows 7
    Saturday, July 29, 2017 1:04 PM
  • Hi,

    To enable the .NET Framework 4.x, you can go to Control Panel, go to this directory "Control Panel\Programs\Programs and Features". On the left side, you'll see a link like "Turn Windows Features on or off", select it. A window will open. Select the .NET Frameworks you want and then click "OK". Wait for install the updates.

    Saturday, July 29, 2017 4:45 PM
  • Windows 7 Service Pack 1?
    If you use Windows 7 SP1, try to download an installation file.
    https://www.microsoft.com/en-gb/download/confirmation.aspx?id=53344


      [Start] > right click [Computer] > Properties

    Ashidacchi

    Sunday, July 30, 2017 1:03 AM
  • It dosn't say which service pack

    Sunday, July 30, 2017 2:26 PM
  • I tried that but it only shows the 3.5.1 version and after  I tried to install the 4.6.2 version the same error appeared

    Sunday, July 30, 2017 2:27 PM
  • I might of forgotten to mention but it's operateing on a 64-bit system if it makes any difference...

    Sunday, July 30, 2017 2:33 PM
  • Hi,

    Welcome to MSDN forum.

    >>The .NET Framework 4.5.x/4.6.x/4.7 is not supported on this operating system.

    For failed installations of the .NET Framework on Windows 7, this message  typically indicates that Windows 7 SP1 is not installed. On Windows 7 systems, the .NET Framework requires Windows 7 SP1. If you are on Windows 7 and have not yet installed Service Pack 1, you will need to do so before installing the .NET Framework. For information on installing Windows 7 SP1, see Learn how to install Windows 7 Service Pack 1 (SP1).

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, July 31, 2017 5:31 AM
  • If System property doesn't show "Service Pack 1", Service Pack 1 is not installed in Windows 7. I suppose it causes this .Net Framework issue. 
    Try to install/update Service Pack 1.

    You can download SP1(KB976932) via Microsoft Update Catalog:
    https://www.catalog.update.microsoft.com/Search.aspx?q=KB976932
    (Please select one according to your Window 7: 64bit/32-bit)
     

    Ashidacchi


    Monday, July 31, 2017 5:47 AM
  • It worked. Thank you so so much
    Monday, July 31, 2017 4:45 PM