none
VS Error: "Could not load file or assembly.. " RRS feed

  • Question

  • Hi,

    I'm developing an Outlook 2010 VSTO add-in (using VS 2015), every time i load the Ribbon(design) i got this error:

    Could not load file or assembly 'Microsoft.Office.Tools.Common.Implementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

    the same error appears when i start the program into debug mode i get the same error  but instead of this line "Microsoft.Office.Tools.common.implementation"  i get "Microsoft.VisualStudio.Tools.Applications.Hosting".

    i assume that this references are missing , and it's would be great from you if send me this files (.dll) with the path where to i should copy it  .

    THANKS :)


     

     

    Sunday, November 13, 2016 1:19 AM

All replies

  • Hello,

    What Office version do you have installed on the problematic machine? Is it Office 2010?

    If so, I'd recommend using a lower VS version for developing Office 2010 add-ins - VS 2013. Note, VSTO allows creating version-specific add-ins. That means you can create Office 2013 and 2016 specific add-ins in Visual Studio 2015 (VSTO is included in paid editions of VS + Community). Did you try to create a new add-in project? Do you get the same error message?

    Also I'd suggest installing the latest updates for your machine, see VS outlook addin ribbon error: “could not load file or assembly”

    Finally, make sure the latest version of VSTO is installed on the machine. Just check out https://aka.ms/GetLatestOfficeDevTools .

    Sunday, November 13, 2016 4:04 PM