none
SQL Database no longer showing up in Azure Portal after rename

    Question

  • I recently restored a SQL Azure Database using PowerShell using the following script.

    function Replace-AzureDatabase
    {
        param
    	(
    		[string]$ResourceGroupName,
    		[string]$ServerName,
    		[string]$SourceDatabaseName,
    		[string]$DestinationDatabaseName,
            [DateTime]$PointInTime,
            [string]$Edition="Standard",
            [string]$ServiceObjectiveName="S0"
    	)
        
        $ErrorActionPreference = "Stop"
    
        $TempDatabaseName = "$($SourceDatabaseName)_$(Get-Random)"
        $Database = Get-AzureRmSqlDatabase -ResourceGroupName $ResourceGroupName -ServerName $ServerName -DatabaseName $SourceDatabaseName
        Restore-AzureRmSqlDatabase -FromPointInTimeBackup -PointInTime (GET-Date).ToUniversalTime() -ResourceGroupName $Database.ResourceGroupName -ServerName $Database.ServerName -TargetDatabaseName $TempDatabaseName -ResourceId $Database.ResourceId -Edition $Edition -ServiceObjectiveName $ServiceObjectiveName
        Remove-AzureRmSqlDatabase -DatabaseName $DestinationDatabaseName -ServerName $ServerName -ResourceGroupName $ResourceGroupName
        Set-AzureRmSqlDatabase -ServerName $ServerName -DatabaseName $TempDatabaseName -NewName $DestinationDatabaseName -ResourceGroupName $ResourceGroupName
    }

    Everything appears to have completed correctly; however, the the database no longer shows up in portions of the Azure Portal.

    It does not appear on:

    • All Resources
    • SQL Databases

    It does appear in the following places:

    • Navigating to the ServerName in All Resources and selecting Database from there.
    • The New All Resources Experience (In Preview)
    • SQL Server management Studio
    • PowerShell via Get-AzureRmSqlDatabase

    I would have just submitted a bug report, but I can't seem to find a place to do that.

    Just in case there was some sort of hiccup during rename I tried renaming it again and renaming it back with no luck.  Any help would be appreciated.

    Thursday, January 10, 2019 9:33 PM

All replies

  • Hi,

    Could you please try logging out and logging in to see if it works. As we are restoring a resource so logging out it good practice to get the expected results.

    Please let us know if you still have face some issues.

    Regards

    Anurag Goyal

    Friday, January 11, 2019 10:53 AM
    Moderator
  • Good day Seth,

    1. My first guess is this is solved already since we are 13 hours after the action.

    Restoring can take long time and you simply need to wait. The time depend on multiple parameters and can easily be several hours until you seethe database under the server.

    Please inform us if the you still do not see the database, what is the database size, and if you remember if the database had a lot of un-committed transaction when you deleted it. 

    2. Regarding the second question, the place to report bugs related to the Azure SQL Database is here:

    https://feedback.azure.com/forums/217321-sql-database

    * But again, this is not necessarily a big yet according to your description :-)


    signature   Ronen Ariely
     [Personal Site]    [Blog]    [Facebook]    [Linkedin]


    Friday, January 11, 2019 11:20 AM
    Moderator
  • The issue is still not resolved.  I tried accessing the portal in 2 separate browsers and had a co-worker try it also, where it displays and where it does not is consistent.

    The database is about 3 GB. There shouldn't have been any uncommitted transactions, the database is for getting ready to roll out a product so there aren't any active users yet.

    Friday, January 11, 2019 6:35 PM
  • Hi Seth,

    Do you have an Azure Support Plan? If you do, please file a support ticket. If not, please send your Azure subscription GUID to AzCommunity at Microsoft.com and I will return instructions to have a support ticket created, as this is a product issue. I look forward to your email.

    Regards,

    Mike

    Friday, January 11, 2019 7:42 PM
    Moderator
  • Hi Seth,

    At this point in time (sry for the late response), this is certainly seems like an issue which need investigation with the ability to examine the specific account, which we cannot do in the forum. I agree with mike, at this point in time and according to your description, if you can open internal ticket then please do so.

    * If you have noway to work directly with the support team (these who have full access to your account), then inform us and we will try to think about workaround, but with the tools we have there is a good chance that we will not have any option.

     


    signature   Ronen Ariely
     [Personal Site]    [Blog]    [Facebook]    [Linkedin]


    Saturday, January 12, 2019 1:50 AM
    Moderator