locked
Swap image question RRS feed

  • Question

  • I have a question concerning the swap image behavior. I have an image, sai its red. I apply the swap image behavior, when hovering over, and go for a blue image. I try this in IE and it works like a charm. When i hover over'it changes into my desired blue image. When i click the image (which has a hyperlink) it still works great. I go back one page and the image has returned to it's original colour red, just like i want it. Now i try this in Firefox. The image changes colour just like it should. I click the image and i go to my desired hyperlink. When I now go back one page the image still has the swap colour (blue) and not my desired original red colour.

    I know a long story for a small question, but i didn't know how to put it differantly.

    Maarten
    Thursday, June 12, 2008 7:18 PM

Answers

  • I've tried the pages in IE7, FF3, Opera 9 and Safari and it works properly for me in all of them.

    The only noticebale thing, in FF and Safari is a small gap underneath 'Examens'. Looking at the code, this is casued by the Tekst Layer div being in the middle of the menu code. If you move this elsewhere in the code it will get rid of the gap. It may even have some effect of the problem you are seeing, although I can't think why it should.

    Ian

    http://www.ew-resource.co.uk
    http://www.fp-resource.co.uk


    Ian Haynes
    Friday, June 13, 2008 9:09 PM

All replies

  • This is going to be easier to solve if we can look at the page. Can you publish it somewhere?

    Ian

    http://www.ew-resource.co.uk
    http://www.fp-resource.co.uk


    Ian Haynes
    Friday, June 13, 2008 9:02 AM
  • Hello Ian,

     

    thank you for replying. The site is unfinished but it's http://www.usf-kempo.nl

    Maarten Dielissen

    Friday, June 13, 2008 6:05 PM
  • Say you press the "examens" button. It goes to the "examens" page. If you press the page back button in your browser you see that the "examens" button still has the swap image and has not restored to the original image. This is only in Fitefox, it works oke in IE.
    Friday, June 13, 2008 7:04 PM
  • I've tried the pages in IE7, FF3, Opera 9 and Safari and it works properly for me in all of them.

    The only noticebale thing, in FF and Safari is a small gap underneath 'Examens'. Looking at the code, this is casued by the Tekst Layer div being in the middle of the menu code. If you move this elsewhere in the code it will get rid of the gap. It may even have some effect of the problem you are seeing, although I can't think why it should.

    Ian

    http://www.ew-resource.co.uk
    http://www.fp-resource.co.uk


    Ian Haynes
    Friday, June 13, 2008 9:09 PM
  • Thank you Ian for your help. I'll have a look at the position of the Tekst Layer Div, to fix that problem

    Maarten
    Saturday, June 14, 2008 7:09 AM