locked
debugging classic asp (slightly different issue) RRS feed

  • Question

  • User2059249242 posted

    first post and I'm not that l33t so please go easy on me.

    I have been running classic asp on IIS7 since I got Vista Ultimate back in Jan (07) I have it set up and working fine. Up until recently I have done all development on this Vista PC, however I recently got a laptop and one of the upshots being I can develop in the living room infront of the TV, however I cannot seem to get meaningful asp error messages from another pc on the network (meaning the Laptop).

    On the PC running IIS7 if I have an error then it gets sent to the browser in the goold old fashioned way;

    Microsoft OLE DB Provider for ODBC Drivers error '80004005'

    [MySQL][ODBC 3.51 Driver]Access denied for user 'root'@'localhost' (using password: YES)

    /testsite/global_config/connection.asp, line 9

    however on my laptop all I get is;

    Server Error
    --------------------------------------------------------------------------------
    HTTP Error 500 - Internal server error.
    Description: There is a problem with the resource you are looking for, and it cannot be displayed.
    --------------------------------------------------------------------------------
    Server Version Information: Internet Information Services 7.0.

    and before you ask - IE7 on the laptop is set not to show friendly http error messages.

    In IIS the under ASP > Debugging Properties > Send Errors To Browser is set to True

    Enable Client-side Debugging and Enable Server-side Debugging are both set to False, however setting these to True does not make any difference, even if I restart the web server.

    Does anyone have any suggestions? If I cannot get meaningful errors on any machine other than this one then that kinda scuppers my plans for developing infront of the TV.

    Yours hopefully,

    Martin

    Tuesday, January 8, 2008 4:12 PM

Answers

  • User511787461 posted

    Run the following from an elevated command prompt on the machine running IIS

    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpErrors -errorMode:Detailed

    The default is to only show detailed error to localhost (so as not to disclose unneeded information to remote clients), this will set it so detailed errors are also sent to remote clients - this is ok to do in a development environment, but shouldn't do in a production environment.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, January 8, 2008 4:24 PM