locked
backend which is hosted on Oracle database (below details). RRS feed

  • Question

  • Hi Team,

    Please provide me the suggestions

    backend which is hosted on Oracle database (below details).
    This connection has to be established using Microsoft Azure data factory's integration runtime. We are running into issues when trying to fetch data and getting below error.
    Please note, connection to DB is established and the error is when fetching data.

    Error:
    Activity OracleDBConnection failed: Failure happened on 'Source' side. 'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=ODBC error 'HY000'.,Source=Microsoft.DataTransfer.ClientLibrary.Odbc.OdbcConnector,''Type=System.Data.Odbc.OdbcException,Message=ERROR [HY000] [Microsoft][ODBC Oracle Wire Protocol driver][Oracle]ORA-22288: file or LOB operation failed ERROR [HY000] [Microsoft][ODBC Oracle Wire Protocol driver][Oracle]ORA-22275: invalid LOB locator specified,Source=msora28.dll,'

    Friday, February 1, 2019 11:20 PM

All replies

  • Hi Srinu,

    There is failure happened on source side – “Invalid LOB locator specified”.

    For the successful completion of DBMS_LOB subprograms, you must provide an input locator that represents a LOB that already exists in the database tablespaces or external file system. For more details, refer “ORA-22275 – Invalid LOB locator specified”.

    This article outlines how to use Copy Activity in Azure Data Factory to copy data from and to an Oracle database.

    Hope this helps.

    Tuesday, February 5, 2019 10:12 AM
  • Just checking in to see if the above answer helped. If this answers your query, do click “Mark as Answer” and Up-Vote for the same. And, if you have any further query do let us know.
    Thursday, February 7, 2019 6:17 AM
  • Hi,

    This is happening because of LOB type of columns in the source database which in your case is oracle.

    I tried and got the same error for LOB type of columns. It works otherwise.

    In my case the column type which caused problem was  MDSYS.SDO_GEOMETRY.

    Moderator(s) can a bug be raised on this feature?

    Kind regards,

    Raj

    Wednesday, June 19, 2019 12:17 AM