none
Twitter Connector - "Could not authenticate your" Error RRS feed

  • Question

  • I've had pretty good success pulling tweets out of twitter using the Twitter Connector.  However, I have only been successful once sending a tweet.  I am trying to send a tweet with a message based off of a trigger.  The value is coming in correctly looking at the log.  However, the connector gives me the following error.

    "Call to Twitter not successful: {\"errors\":[{\"code\":32,\"message\":\"Could not authenticate you.\"}]}"

    I thought it might be an issue with my session, so I deleted my entire Logic App and recreated it and reauthenticated as well. It still doesn't work.


    Corey Roth - SharePoint Server MVP blog: www.dotnetmafia.com twitter: @coreyroth | SP2 Apps

    Friday, March 27, 2015 4:36 PM

Answers

  • I ran into this also.

    Per Stephen's reply, I tried running the Twitter tweet action with only alpha characters (originally had both @ and ! in the tweet) and after removing all the non-alphanumeric characters, the tweet went through fine.

    Tuesday, March 31, 2015 9:06 PM

All replies

  • Could you share the inputs that you are providing to the connector (you'll see it under Inputs Link on the action blade)?

    We had an issue where certain non-alphanumeric characters were causing errors like the above, so it'd be great if we could see what you're sending.

    Saturday, March 28, 2015 6:14 PM
    Moderator
  • Hi Stephen,

    Here are the additional details you requested.  Typically, I would just add a list item with a title of something like this "This is an @Azure Logic App Test Tweet".  

    Here is a screenshot of the triggers and actions:

    Here is the input text.

    {
        "host": {
            "gateway": "https://default-web-southcentraluse58f886843cd4c06bbe282a04c169cd3.azurewebsites.net/",
            "id": "/subscriptions/e58f8868-43cd-4c06-bbe2-82a04c169cd3/resourcegroups/default-web-southcentralus/providers/Microsoft.AppService/apiapps/twitterconnector"
        },
        "operation": "PostTweet",
        "parameters": {
            "TweetText": "\"This is an @Azure Logic App Test Tweet!\""
        },
        "apiVersion": "2015-01-14",
        "authentication": {
            "scheme": "Zumo",
            "type": "Raw"
        }
    }

    Here is the output it gives me:

    {
        "headers": {
            "pragma": "no-cache,no-cache",
            "x-Content-Type-Options": "nosniff",
            "x-ms-proxy-outgoing-newurl": "https://twitterconnectorbe5409e360804058bca7778c1347f4b2.azurewebsites.net/statuses/update?TweetText=\"This+is+an+%40Azure+Logic+App+Test+Tweet!\"",
            "cache-Control": "no-cache",
            "set-Cookie": "ARRAffinity=ae6e6de736b8fd9090b23b5b3bdf2efb5e67251f63bd7e775f1e5d3db2cf47a7;Path=/;Domain=default-web-southcentraluse58f886843cd4c06bbe282a04c169cd3.azurewebsites.net,ARRAffinity=cc525ce7951b8d8764c5749b0f6863effe9ce8b72e42cfd6f3a6507c2f5b7992;Path=/;Domain=default-web-southcentraluse58f886843cd4c06bbe282a04c169cd3.azurewebsites.net",
            "server": "Microsoft-IIS/8.0",
            "wwW-Authenticate": "Basic realm=\"Service\"",
            "x-AspNet-Version": "4.0.30319",
            "x-Powered-By": "ASP.NET,ASP.NET",
            "date": "Mon, 30 Mar 2015 13:44:46 GMT"
        },
        "body": {
            "status": 0,
            "source": "https://twitterconnectorbe5409e360804058bca7778c1347f4b2.azurewebsites.net/statuses/update?TweetText=\"This+is+an+%40Azure+Logic+App+Test+Tweet!\"",
            "message": "Call to Twitter not successful: {\"errors\":[{\"code\":32,\"message\":\"Could not authenticate you.\"}]}"
        }
    }



    Corey Roth - SharePoint Server MVP blog: www.dotnetmafia.com twitter: @coreyroth | SP2 Apps

    Monday, March 30, 2015 1:58 PM
  • I ran into this also.

    Per Stephen's reply, I tried running the Twitter tweet action with only alpha characters (originally had both @ and ! in the tweet) and after removing all the non-alphanumeric characters, the tweet went through fine.

    Tuesday, March 31, 2015 9:06 PM