locked
VS 2005 and IIS7 RRS feed

  • Question

  • User-858731793 posted

     OK, I am trying to view a local website on Vista Ultimate, IIS7 and VS 2005. I'm getting the standard error:

    To access local IIS Web sites, you must install all of the following Windows components:

    Internet Information Services
    IIS 6 Metabase and IIS 6 Configuration Compatibility
    ASP.NET

    In addition, you must run Visual Studio in the context of an administrator account. By default, Windows runs applications in a limited-privilege user account even when you are logged on to the computer as an administrator. To run Visual Studio with administrative privileges, right-click the Visual Studio icon and then click 'Run as administrator'.

    I have done all of this stuff (plenty of posts on how to do it) but it's still not working. Anyone have any other ideas?

    -J

    Friday, September 11, 2009 7:08 PM

Answers

  • User-858731793 posted

    Yeah, I have done that a hundred times.

     

    Here is what ended up fixing the problem: I ran a script that went through the registry and file system and "fixed" the permissions on tons of objects. Now I no longer get an error when opening a local IIS website.

    The script is explained here:

    http://blogs.msdn.com/astebner/archive/2006/09/04/739820.aspx

     

    -J

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, September 15, 2009 9:01 AM

All replies

  • User-880529193 posted

    Hi,

    try to uninstall your vs and iis. Then try to Install firts the IIS before your VS 

    Friday, September 11, 2009 10:32 PM
  • User1282515047 posted

    Hi jonbprime, well try this options:

    1. Verify that you have all Service pack for visual studio 2005 (SP1 i think is the last one).
    2. After that you must go to IIS and search your virtual directory of your Application and right click over Convert to application.
    3. Run Visual Studio with Administrator Privilegies.
    Regards.

    Friday, September 11, 2009 10:35 PM
  • User-858731793 posted

     NecroxPy, I have tried that, still no luck...

     

    I think I may have to try and re-install VS which is a bummer because then I have to re-install all the other packs and add-ons.

     

    Thanks,

    -Jon

    Monday, September 14, 2009 10:49 AM
  • User1282515047 posted

    Have you got Firewall? If you have it you must enable the right program and/or port.

    Regards.

    Monday, September 14, 2009 3:22 PM
  • User-858731793 posted

     Turned off the firewall but it made no difference. Uninstalling VS now...

    Monday, September 14, 2009 4:49 PM
  • User-1492568288 posted

    Try turnning on the following Windows features:

    Internet Information Services
    IIS 6 Metabase and IIS 6 Configuration Compatibility
    ASP.NET

    Via Control Panel > Programs > Turn Windows features on or off

    Thanks.

    Tuesday, September 15, 2009 6:16 AM
  • User-858731793 posted

    Yeah, I have done that a hundred times.

     

    Here is what ended up fixing the problem: I ran a script that went through the registry and file system and "fixed" the permissions on tons of objects. Now I no longer get an error when opening a local IIS website.

    The script is explained here:

    http://blogs.msdn.com/astebner/archive/2006/09/04/739820.aspx

     

    -J

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, September 15, 2009 9:01 AM