locked
Windows Server folder permissions - Windows explorer vs C# settings RRS feed

  • Question

  • Hi All, I have an issue with windows folder permissions that I just can not figure out. I'm kinda new at all this (previous program owner did a dump and run), so any help would be much appreciated!

    I've created code that will add individual users to folders and give them the permission types depending on their role - viewers only get read; submitters get read write. Using C# in VS, that all seems to work fine. I see the indv users added with proper permissions to the folders I direct them to.

    However, when I remove the "Everyone", the user (me, while testing) can no longer access the folders through the web to the windows server. I can access via Windows Explorer, but when I try via the web https: //<server>/folder.... I get an access denied.

    I am trying to add the user names only to the folders for security purposes when they access the files directly using the web.

    Does anyone know what settings I need at the window server to make this work? I tried to add "user" (anyone can go there and snoop - just like adding "Everyone"), "Authenticated User" (was kinda buggy and didn't let some approved users in).

    Anyway, I'm at a loss...

    Thanks!

    DueyS

    Tuesday, November 3, 2015 8:25 PM

Answers

  • I saw you are access the folder using https: //<server>/folder instead of \\<server>\folder. In your case, you need to set your permission in IIS server and not only Windows Explorer.

    Enable or Disable Directory Browsing in IIS 7

    https://technet.microsoft.com/en-us/library/cc731109(v=ws.10).aspx

    chanmm


    chanmm

    • Marked as answer by DueyS Thursday, November 5, 2015 3:47 PM
    Wednesday, November 4, 2015 1:37 AM

All replies

  • Maybe you need IP Address and Domain Restrictions
    Tuesday, November 3, 2015 8:34 PM
  • I am trying to add the user names only to the folders for security purposes when they access the files directly using the web.

    What are you talking? Do have some kind program trying to access the folder that is a Web application running on a Web server?

    Wednesday, November 4, 2015 12:21 AM
  • I saw you are access the folder using https: //<server>/folder instead of \\<server>\folder. In your case, you need to set your permission in IIS server and not only Windows Explorer.

    Enable or Disable Directory Browsing in IIS 7

    https://technet.microsoft.com/en-us/library/cc731109(v=ws.10).aspx

    chanmm


    chanmm

    • Marked as answer by DueyS Thursday, November 5, 2015 3:47 PM
    Wednesday, November 4, 2015 1:37 AM
  • Chanmm, thank you! I think disabling browsing is just what I needed. I'll run it by my user today.

    Thanks again!

    Duey S

    The more I learn, the more I realize I don't know...

    Thursday, November 5, 2015 3:49 PM