locked
Session cookies??? RRS feed

  • Question

  • I update my website often and I want viewers to see the latest version.  It doesn't seem reasonable that viewers would need to clear cookies and caches as my host (Siteground) claims.  Don't understand why the latest version doesn't appear after I publish.  I use Expression Web 4 and view with IE and Firefox.  Have looked at code for other sites and do not see anything helpful.  There has to be a simple fix (I hope!)  

    Thanks

    Wednesday, August 15, 2012 9:34 PM

Answers

  • Get a host that doesn't tell you nonsense.  :)

    I see new sites instantly.  My browser is set to check for new content on each page load.  My ISP doesn't cache sites (old AOL was notorious for that).

    If you aren't seeing new content, it's your ISP, your brower settngs, or perhaps you are instructing Siteground to cache your site.  (Googling finds: http://kb.siteground.com/article/How_to_speed_up_your_site_by_remote_caching_static_content.html )

    Regardless, this is not an Expression Web question.


    • Edited by KathyW2 Wednesday, August 15, 2012 10:08 PM
    • Marked as answer by echoeranch Thursday, August 16, 2012 5:00 PM
    Wednesday, August 15, 2012 10:07 PM
  • Some servers cache pages for faster delivery, and you have to wait for the cache to update.

    Also, have you tried a forced refresh:  Ctrl+F5 to ensure the browser goes to the server instead of looking in the temporary internet files.


    Expression Web MVP


    • Edited by Steve Easton Wednesday, August 15, 2012 10:09 PM
    • Marked as answer by echoeranch Thursday, August 16, 2012 5:00 PM
    Wednesday, August 15, 2012 10:08 PM
  • This issue generally relates to a local user's browser configuration setting you would normally have no control over (and it is not really strictly an EW-specific issue) but there is a work around, (at least it is one solution you can try) as detailed in this page - "Force your Page always to load from Server not from the web cache".  There are other related articles linked from that site about browser cache behaviour that may be of interest to you.

    Insert the code below, into your <head> section of the code of each and every page.  Republish all the HTML files.  From there, you should hopefully see a difference in its loading.  If you have lots of pages, this may be a bit of effort, but if you use Dynamic Web Templates,should be relatively painless, just update the DWT file, it applies the change to all attached pages. You then would need to republish all pages.

    <meta http-equiv="expires" content="0"> 

    How do other browsers behave with respect to the caching issue -I would suggest expanding your testing routine to the other standard browsers e.g. Safari, Opera, Google Chrome etc.


    Andrew M


    http://www.murraywebs.com

    "Nothing spoils numbers faster than arithmetic!"
    -- Peppermint Patty (Peanuts, Charles M. Schulz)



    • Edited by AndrewOZ1 Wednesday, August 15, 2012 10:17 PM
    • Marked as answer by echoeranch Thursday, August 16, 2012 5:00 PM
    Wednesday, August 15, 2012 10:12 PM

All replies

  • Get a host that doesn't tell you nonsense.  :)

    I see new sites instantly.  My browser is set to check for new content on each page load.  My ISP doesn't cache sites (old AOL was notorious for that).

    If you aren't seeing new content, it's your ISP, your brower settngs, or perhaps you are instructing Siteground to cache your site.  (Googling finds: http://kb.siteground.com/article/How_to_speed_up_your_site_by_remote_caching_static_content.html )

    Regardless, this is not an Expression Web question.


    • Edited by KathyW2 Wednesday, August 15, 2012 10:08 PM
    • Marked as answer by echoeranch Thursday, August 16, 2012 5:00 PM
    Wednesday, August 15, 2012 10:07 PM
  • Some servers cache pages for faster delivery, and you have to wait for the cache to update.

    Also, have you tried a forced refresh:  Ctrl+F5 to ensure the browser goes to the server instead of looking in the temporary internet files.


    Expression Web MVP


    • Edited by Steve Easton Wednesday, August 15, 2012 10:09 PM
    • Marked as answer by echoeranch Thursday, August 16, 2012 5:00 PM
    Wednesday, August 15, 2012 10:08 PM
  • This issue generally relates to a local user's browser configuration setting you would normally have no control over (and it is not really strictly an EW-specific issue) but there is a work around, (at least it is one solution you can try) as detailed in this page - "Force your Page always to load from Server not from the web cache".  There are other related articles linked from that site about browser cache behaviour that may be of interest to you.

    Insert the code below, into your <head> section of the code of each and every page.  Republish all the HTML files.  From there, you should hopefully see a difference in its loading.  If you have lots of pages, this may be a bit of effort, but if you use Dynamic Web Templates,should be relatively painless, just update the DWT file, it applies the change to all attached pages. You then would need to republish all pages.

    <meta http-equiv="expires" content="0"> 

    How do other browsers behave with respect to the caching issue -I would suggest expanding your testing routine to the other standard browsers e.g. Safari, Opera, Google Chrome etc.


    Andrew M


    http://www.murraywebs.com

    "Nothing spoils numbers faster than arithmetic!"
    -- Peppermint Patty (Peanuts, Charles M. Schulz)



    • Edited by AndrewOZ1 Wednesday, August 15, 2012 10:17 PM
    • Marked as answer by echoeranch Thursday, August 16, 2012 5:00 PM
    Wednesday, August 15, 2012 10:12 PM