The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Azure Virtual Machines!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 none
Unable to Ping Failover Cluster RRS feed

  • Question

  • From: Harnil @harnilkpandya via Twitter

    I am facing connection issues while implementing Windows Server Fail-over Cluster on Azure. I used below work-around but while pinging VIP from other VMs, it is not reachable: https://blogs.msdn.microsoft.com/mast/2015/06/17/building-windows-server-failover-cluster-on-azure-iaas-vm-part-2-network/#comment-6026

    I have configured failover cluster on one Azure VM. The cluster is up and running but when I ping the virtual IP from other VM. That Virtual IP is not reachable from other VMs. I applied powershell work-around to make it work but not working. I am not receiving any error but in that case I should be able to ping to that Virtual IP to use failover.

    Thanks

    @AzureSupport

    Wednesday, June 1, 2016 8:57 PM

All replies

  • Setting up the failover cluster IP is very complicated and in depth, but here's a link:

    https://clusteringformeremortals.com/2016/01/06/configuring-the-azure-ilb-in-arm-for-sql-server-fci-or-ag-using-azure-powershell-1-0/

    And my shot in the dark, did you run the following powershell command from the above link?

    Get-ClusterResource
    $IPResourceName | Set-ClusterParameter -Multiple
    @{"Address"="$ILBIP";"ProbePort"="59999";"SubnetMask"="255.255.255.255";
    `

    "Network"="$ClusterNetworkName";"OverrideAddressMatch"=1;"EnableDhcp"=0}


    • Proposed as answer by Chomet Wednesday, November 14, 2018 6:49 AM
    Wednesday, June 1, 2016 9:35 PM
  • Dear Azure Team,

    Thank you for taking interest into this matter. I am implementing failover cluster on Azure VM and what it seems that directly it doesn't work based on the below thread:

    https://blogs.msdn.microsoft.com/mast/2015/06/17/building-windows-server-failover-cluster-on-azure-iaas-vm-part-2-network/#comment-6026

    So I applied the work around to create Virtual IP. It is created but while pinging that it doesn't establish connection. I am not able to attach screenshot till you verify my account.

    Wednesday, June 1, 2016 9:40 PM
  • Yes, I have as mentioned below. I also get the warning which as expected.

    PS C:\Windows\system32> Get-ClusterResource $IPResourceName | Set-ClusterParameter -Multiple @{"Address"="$ILBIP"; "ProbePort"="59999";"SubnetMask"="255.255.255.255";"Network"="$ClusterNetworkName"; "OverrideAddressMatch"=1;"EnableDhcp"=0}
    WARNING: The properties were stored, but not all changes will take effect until Cluster IP Address is 
    taken offline and then online again.

    Wednesday, June 1, 2016 10:03 PM
  • When I set mine up I ran into the same issue, and ended up going through that link I provided step by step to make sure I didn't miss anything, and the powershell command ended up being what fixed it for me. There's so many moving pieces it's hard to guess what might be wrong, the ILB probe and rules in the Azure Portal I remember being an important part you might want to double check..
    Wednesday, June 1, 2016 10:52 PM
  • Were you able to get this figured out? I"m having the same issue and I also followed all instructions, including the <g class="gr_ gr_82 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="82" id="82">powershell</g> script mentioned. Thanks!
    Saturday, September 1, 2018 5:27 PM