locked
Ramdom symbols in the address bar with IIS project RRS feed

  • Question

  • User-1987148307 posted

    Hello everyone,

    I have one site that before it was in .NET Framework 1.1, and in that time when I access to it in the address bar the url appeared something like http://localhost/myapp/(S(xbxuabjc25dmpig2pvo4vowa))/Default.aspx when it should be only http://localhost/myapp/Default.aspx. Some days ago I merged the app to .NET Frawork 4.5 hoping this issue where removed but the problem is still there, so now I think the problem occurs in the IIS settings, but I don't know what could be.

    I use IIS 7.0.

    I hope you can help me I have several days with this issue :(. Before anything, thanks in advance.

    Regards.

    Wednesday, April 30, 2014 4:37 PM

Answers

  • User-760709272 posted

    It is using cookieless sessions.  Google it for info on turning it off, note that IE10 (I think) had a bug that make the site think sessions were cookieless when they weren't and there is a patch for it.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, April 30, 2014 5:53 PM

All replies

  • User-760709272 posted

    It is using cookieless sessions.  Google it for info on turning it off, note that IE10 (I think) had a bug that make the site think sessions were cookieless when they weren't and there is a patch for it.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, April 30, 2014 5:53 PM
  • User-1987148307 posted

    You're right, thank you so much. For the IE there's no problem because I'm using IE9 ;).

    Regards

    Thursday, May 1, 2014 10:08 AM