none
can't compare preinstall and postinstall snap shots in Windows system state analyzer version 3.0 RRS feed

  • Question

  • after I generated the two snap shots, I tried to compare them by using loading the tool created two bin files, then when I run it, I got "insert addedKeys" error message twice, then got the tool stopped working message.

    so I just wonder if someone has seen this problem, and have solution for it.

    Thanks for your help,

    Qin  

    Tuesday, January 11, 2011 7:06 PM

All replies

  • Here is what I got from MS support team:

    The Logo Program is aware of the issues some are seeing with the Windows System State Analyzer and are working on a fix to be released soon.

     

    In the meantime, some machines do not repro issues, so you may attempt on another machine, or move .bin files to another machine and run comparison.

     

    We recommend running the Windows System State Monitor as a quicker workaround. The tool provides close to the same functionality and reporting only in real time, and is included in the Software Certification Toolkit.

     

    Start Monitoring, run your testing, Stop Monitoring, then choose to Create Report.

     

    Hope this helps as a workaround.

     

    Thursday, January 13, 2011 5:48 PM
  • Hi Qin_2011

    Have you been sucessfull using WSSM?

    We are having the same issue with WSSA and trying to use WSSM as workaround.

    How do you get to know whether the result is a pass or no-pass based on the reports?

     

    Regards.

    Thursday, January 27, 2011 12:35 PM
  • Hi,

     

    I tried to use the monitor to compare preinstall and post-install state, but it didn’t really work for me, because it was hard to tell which was new after installation,  when had to manually look for a difference, that was time consuming.

     

    Thanks,

    Wednesday, February 9, 2011 8:37 PM
  • I was having the same problem but without the "insert addedKeys" error message.  The status displayed busy: (Comparing) but nothing happened.  I then run the application using the cmd prompt and was able to see that the problem seems to be generating the report.  This is what the output looks like:

    C:\Program Files\Microsoft Logo\Software Certification Toolkit\Windows System State Analyzer>sanalyzer.exe compare file1.bin file2.bin /A CompareResult.html

    Comparing snapshot..........
    Snapshot compare complete
    Generating Report...../compareresult.html
    ^C

    It remained there for hours until I finally killed the process.  Then I tried using different options like /S for the services, /D for drivers and it worked.  The result is that I ended up with separate reports instead of one.

    I hope it helps

    Claudia

    • Proposed as answer by Domenico Manno Tuesday, October 27, 2015 1:38 AM
    Monday, February 28, 2011 5:55 PM
  • Claudia,

    I just want to thank you for this post. It definitely helped me a ton! Just when I was ready to give up after trying so much other stuff!!! 

    Warm Regards,

    Dom

    Tuesday, October 27, 2015 1:38 AM