locked
Windows 8.1 app in Win 10 - Refresh problem? RRS feed

  • Question

  • User94948 posted

    We are experiencing a very strange problem with a Xama Forms app for Win 8.1 running on Win 10. A View that works perfectly on all the other platforms: Andro, iOS, Win 8.1, has a refresh problem on Win 10. The grid table items are correctly loaded, but after a moment they disappears. To see they, in pc mode, you can resize the app window. The grid table items appears for a moment and then disappears. You can’t see the items, but they are active. The click on the invisible items works and open the relative detail window. Clicking the back button and then going back to the original view same problem, the items appears for a moment, and then disappears.

    To screeshot SS01 is the right view, and SS02 the empty one after a moment when the items disappears.

    Any one has experienced a similar problems?

    Thanks!

    Thursday, December 3, 2015 6:11 PM

All replies

  • User69837 posted

    It would be best to create a bug with a small repro at http://bugzilla.xamarin.com

    Thursday, December 3, 2015 6:26 PM
  • User172849 posted

    I have also noticed that Observable Collections are not working properly in WinRT (Windows Phone 8.1).

    I have pages that have observable collections on them, and when the items in the list change, the elements in the UI just disappear. I suspect this is the same problem that you are having.

    Thursday, December 3, 2015 7:42 PM
  • User94948 posted

    I have isolated the origin of the problem, seem not related to the observable collections, but to ScrollView.

    The “invisible” grid table items are handled by our component AW\PaintAnatomy\Shared\AW.PaintAnatomy\LgcListView_H. That component use the following xaml

    and in SearchView.WithScrollView.jpg you can see the resulting view. The items are really inside, but visible only for a moment after a win refresh (resize, back, etc).

    If I replace the ScrollView with a StackLayout like below;

    The grid table items don’t disappear any more as you can see in SearchView.WithStackLayout.jpg!

    Obviously that is not a solution because I need the scroll!

    That is very strange because that component is widely used in our app, but the problem appears only on Win 10 in that specifically instance :-(

    Friday, December 4, 2015 1:23 PM
  • User94948 posted

    I noticed the xml was not correctly posted. I rewrote the post.

    I have isolated the origin of the problem, seem not related to the observable collections, but to ScrollView.

    The “invisible” grid table items are handled by our component AW\PaintAnatomy\Shared\AW.PaintAnatomy\LgcListView_H. That component use the following xaml

    < ScrollView xmlns="http://xamarin.com/schemas/2014/forms" xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml" x:Class="AW.PaintAnatomy.CustomControls.LgcListView_H" Orientation="Horizontal" > < StackLayout x:Name="slItems" VerticalOptions="FillAndExpand" HorizontalOptions="FillAndExpand" Orientation="Horizontal" >< /StackLayout> < /ScrollView >

    and in SearchView.WithScrollView.jpg you can see the resulting view. The items are really inside, but visible only for a moment after a win refresh (resize, back, etc).

    If I replace the ScrollView with a StackLayout like below;

    < StackLayout xmlns="http://xamarin.com/schemas/2014/forms" xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml" x:Class="AW.PaintAnatomy.CustomControls.LgcListView_H" Orientation="Horizontal"> < StackLayout x:Name="slItems" VerticalOptions="FillAndExpand" HorizontalOptions="FillAndExpand" Orientation="Horizontal" >< /StackLayout> < /StackLayout>

    The grid table items don’t disappear any more as you can see in SearchView.WithStackLayout.jpg!

    Obviously that is not a solution because I need the scroll!

    That is very strange because that component is widely used in our app, but the problem appears only on Win 10 in that specifically instance :-(

    Friday, December 4, 2015 2:30 PM