locked
Illegal characters in path RRS feed

  • Question

  • User31164289 posted

    Trying to login system shows this error:

    Illegal characters in path

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentException: Illegal characters in path.

    Source Error:

    Line 7:      Protected Sub btLogin_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles btLogin.Click
    Line 8:  
    Line 9: If Membership.ValidateUser(txtUserName.Value, txtPassword.Value) Then Line 10: 
    Line 11:             Dim authTicket As FormsAuthenticationTicket = New FormsAuthenticationTicket(txtUserName.Value, True, (12 * 60))

    What is the problem? On my pc in visual studio all work great!!

    Thursday, October 13, 2011 6:32 PM

All replies

  • User197322208 posted

    What do you have in web.config as connection string for

    Membership

    ?
    Thursday, October 13, 2011 10:08 PM
  • User31164289 posted
    <membership defaultProvider="AccessMembershipProvider">
    <providers>
    <clear/>
    <add name="AccessMembershipProvider" type="Samples.AccessProviders.AccessMembershipProvider, SampleAccessProviders" connectionStringName="AccessFileName" enablePasswordRetrieval="false" enablePasswordReset="true" requiresUniqueEmail="false" requiresQuestionAndAnswer="false" minRequiredPasswordLength="1" minRequiredNonalphanumericCharacters="0" applicationName="SampleSite" hashAlgorithmType="SHA1" passwordFormat="Hashed"/>
    </providers>
    </membership>
    
    
    and this is string connection
    <connectionStrings>
    <add name="AccessFileName" connectionString="Provider=Microsoft.Jet.Oledb.4.0;Data Source=|DataDirectory|ASPNetDB.mdb"
    providerName="System.Data.OleDb" />
    <add name="ASPNetDBConnectionString" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=|DataDirectory|\ASPNetDB.mdb;Persist Security Info=True"
    providerName="System.Data.OleDb" />
    </connectionStrings>
    Friday, October 14, 2011 1:02 AM
  • User197322208 posted

    Do not know what version is the correct one....

    Data Source=|DataDirectory|ASPNetDB.mdb"

    Data Source=|DataDirectory|\ASPNetDB.mdb

    Try changin both with

    \

    and changing both without

    \

    Friday, October 14, 2011 2:57 AM
  • User31164289 posted

    Nothing. I've still tried this. Not work.

    This settings work perfectly on my PC. 

    On webserver (windows 2008) shows this error..

    There must be a workaround..

    Friday, October 14, 2011 3:41 AM
  • User-1199946673 posted

    Which result do you get if you do:

    Response.Write(Server.MapPath("~/app_data/"))
    Friday, October 14, 2011 3:59 AM
  • User31164289 posted

    C:\inetpub\wwwroot\Mobile\app_data\

    Friday, October 14, 2011 5:48 AM
  • User-1199946673 posted

    Try

    <add name="AccessFileName" connectionString="Provider=Microsoft.Jet.Oledb.4.0;Data Source=C:\inetpub\wwwroot\Mobile\app_data\ASPNetDB.mdb"
         providerName="System.Data.OleDb" />

    Friday, October 14, 2011 6:59 AM
  • User31164289 posted

    Now this is error:

    AccessFile is not valid: C:\inetpub\wwwroot\Mobile\Provider=Microsoft.Jet.Oledb.4.0;Data Source=C:\inetpub\wwwroot\Mobile\app_data\ASPNetDB.mdb

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.Exception: AccessFile is not valid: C:\inetpub\wwwroot\Mobile\Provider=Microsoft.Jet.Oledb.4.0;Data Source=C:\inetpub\wwwroot\Mobile\app_data\ASPNetDB.mdb

    But this file is the same that I'm using in another webapp..

    Friday, October 14, 2011 8:28 AM
  • User197322208 posted

    But this file is the same that I'm using in another webapp..

    Replace it.

    Friday, October 14, 2011 9:48 AM
  • User31164289 posted

    Done but .. don't work!

    I'm very exasperated!

    Friday, October 14, 2011 9:55 AM
  • User-1199946673 posted

    I think you need to debug the source code of your membership provider, so see what's going on....

    Friday, October 14, 2011 10:49 AM
  • User3866881 posted

    Nothing. I've still tried this. Not work.

    This settings work perfectly on my PC. 

    On webserver (windows 2008) shows this error..

    There must be a workaround..

    Hello:)

    How did you deploy your proj onto the Win2008 Server?

    Friday, October 14, 2011 11:35 PM