locked
Can't Install, WshShell.Exec error RRS feed

  • Question

  • User-95264152 posted

    When I try and run "cscript fcgisetup.js /install" I get the following:

     fcgisetup.js(406, 2) WshShell.Exec: The system cannot find the path specified"

    I can't find anything on this error searching google, how can I fix this, or install FastCGI for php manualy?

    Thursday, April 19, 2007 6:02 AM

All replies

  • User-679828332 posted

    Hi Canadaka,

    Perusing the script suggests that the variable launchPath has the incorrect value, causing WScript.Exec to fail.

    What is the directory you're running the script from? (ie. the current directory)

    Is this machine 64-bit?

    Thanks,

    Rick.

    Thursday, April 19, 2007 1:11 PM
  • User-95264152 posted

    No, I am running the 32bit version of Windows 2003, and its running from "C:\Inetpub\fastcgi" and i even tried moving the files and running from "C:\WINDOWS\system32".

    Strange thing is, back a couple months ago I tried out the first releast of FastCGI and used this same install processs and it worked fine. I also used the outline uninstall at the time.

    I would very much like to test out this new release, to see if it's more stable in my enviroment.

    Thursday, April 19, 2007 5:19 PM
  • User-679828332 posted

    Could you WScript.Echo to the script for the arguments to the failing WScript.Exec call?

    e.g. WScript.Echo( variablename );

    Friday, April 20, 2007 1:22 AM
  • User-95264152 posted

    ok I feel like a complete idiot now, after skimming through the fcgisetup.js to the line with the error then following where each variable comes from I realised its looking for files in the /x86 folder. Which i removed, I just dumped all the times into the same folder.

     SO I got fastCGI installed, but it doesn't really work, It loaded the first page fine, the phpinfo() test page, but anything else it just sits there forever trying to load. Sometimes the page eventual loads after a minute or two. I even tried turning all my sites back to the PHP ISAPI except 1 site, and that 1 site using fastCGi had the same extreme slowness and hanging.

    Friday, April 20, 2007 3:40 AM
  • User-95264152 posted

    I am running PHP 5.2.1 and MySQL 5.1.11

    Both "fcgiext.dll" and "php-cgi.exe" are set to allowed in the IIS Service extensions. And when I try to run fastcgi, it is the only mapping to .php, I removed the old one that used the php isapi dll. When i was able to slowly load the phpinfo() page the info was correct, listed the correct php.ini path and was running under fastcgi.

    So i'm not sure what the issue is, I gave everything a nice restart after and still the same slow or not loading at all results.

    Is there any settings in the php.ini that could cause this?

    Friday, April 20, 2007 3:52 AM
  • User-679828332 posted

    Hi canadaka,

    When you say "slowly load the phpinfo" - do you mean it took more than 1 second?

    Can you share your fcgiext.ini file settings?

    Can you share your phpinfo script?

    Thanks,

    Rick.

    Friday, April 20, 2007 9:32 PM