none
Using report viewer 8.0 with a project built against 9.0 RRS feed

  • Question

  • Hi,

    I've built and deployed a web project which uses the report viewer control. The project was built against Microsoft.ReportViewer 9.0.0.0 . However I need it to be 8.0.0.0. I've changed all the references in the web config to point to version 8.0.0.0 but I'm getting this error:

    Exception message: (0): error CS1705: Assembly xx.xx.xx, Version=2.0.0.18, Culture=neutral, PublicKeyToken=null' uses 'Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' which has a higher version than referenced assembly 'Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

    Is it possible to set the reference to an earlier version?

    Thanks.

    Tuesday, December 14, 2010 5:32 PM