none
Microsoft.ACE.OLEDB.12.0 is not registered RRS feed

  • Question

  • hello i am getting the  Microsoft.ACE.OLEDB.12.0 is not registered  on local machine error. I have installed the micrsoft driver also. I am not able to find platform option.. Properties->compile->advance compile but not getting option. Tools->option not getting, Build-> not getting. My processor is 64 bit, Ms office is 2007,Vb.net framework 2008 4.0 version(download through microsoft site). Since 2 day i am searching on net but no solution.Tried the solution show on this topic but no help.please guide me..

    • Moved by edhickey Monday, July 18, 2011 2:02 PM (From:.NET 4: Windows Workflow Foundation)
    Saturday, July 16, 2011 8:23 PM

Answers

  • Access does not have a 64bit edition until 2010

    before 2010, you need to change the target platform to X86, not AnyCPU.

    You need to turn on the expert mode to see the platform settings if you are using the Express edition.



    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP
    Monday, July 18, 2011 4:24 PM

All replies

  • Access does not have a 64bit edition until 2010

    before 2010, you need to change the target platform to X86, not AnyCPU.

    You need to turn on the expert mode to see the platform settings if you are using the Express edition.



    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP
    Monday, July 18, 2011 4:24 PM
  • I have a similar problem, not a web app - straight C# windows app, on 64 bit. I don't mind making it a 32 bit app, and using the 32-bit drivers, but not sure since you say to not use "Any CPU" - which is the ONLY option under Build for "Platform".

     

    I do have "Platform Target", and can select "x86", "x64" or "Any CPU". Here are the build options.

     

     

    I've installed the 2010 "Microsoft Access database engine 2010" for 32 bit. Windows, however, is 64 bit. This shouldn't matter - in fact, I CAN NOT install the 64 bit version of the engine for 2010 because I have 32-bit office 2007 installed. This did not prevent installation of the 2010 engine, as long as it is also 32 bit.

    Here is the connect string:

    So... the application is 32 bit, the Access Database Engine 2010 is 32-bit. But I still get the same error about the driver not being installed. Programs-and-Features shows: "Microsoft Access database engine 2010 (English)" installed.

     

    What do I try next?
    Tuesday, August 23, 2011 11:57 PM
  • If you are using C# Express, check http://social.msdn.microsoft.com/forums/en-us/Vsexpressvcs/thread/08ADC799-E705-47D1-940C-3F91EF442CEC

    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP
    Wednesday, August 24, 2011 8:20 PM