none
Azure Data Lake Analytic never finishes compilation

    Question

  • Hi,

    I'm trying to run the simple script but it could not be compiled.

    There were no problems before yesterday.


    USE DATABASE master;
    USE SCHEMA dbo;
    @mix = 
        EXTRACT date DateTime,
                time long,
                eventName string,
                distinct_id string,
                app string
    	FROM "/mixpanel/statuses/{date:yyyy}/{date:MM}/{date:dd}/{app:*}.csv" 
    	USING Extractors.Csv(quoting:false, skipFirstNRows : 1);
    
    @mix= SELECT distinct_id, 
                   app,
                   time,
                   time - LAG(time, 1) OVER( PARTITION BY distinct_id, app ORDER BY time ASC) AS Delta 
            FROM @mix 
            WHERE eventName == "AppStarted";
    
    
    OUTPUT @mix TO "/export/mix_report.csv" USING Outputters.Csv(outputHeader: true);


    Thursday, May 11, 2017 8:15 AM

All replies

  • Is the error in your local environment or in Azure? If in Azure, please create a support ticket directly from the job in the portal, so that the support team can investigate
    Thursday, May 11, 2017 8:46 AM
  • The problem is in this line:

    FROM "/mixpanel/statuses/{date:yyyy}/{date:MM}/{date:dd}/{app:*}.csv" 

    if I replace it by

    FROM "/mixpanel/statuses/{*}/{*}/{*}/{*}.csv" 

    then compilation can finish.

    Thursday, May 11, 2017 8:49 AM
  • Sorry - my previous answer was not relevant. If the problem is not solved, can you share the compilation error you got before? I tried your code snippet and it seems to compile ok for me.
    Tuesday, May 16, 2017 1:55 AM