locked
Problems with iframe in IE8, IE9 & IE10 RRS feed

  • Question

  • Hi there

    We are experiencing a strange problem in several different versions of IE (IE8, IE9 & IE10). On our main website, we have a usercontrol which generates an iframe in the background, connects to another one of our sites hosted in-house and drops 2 cookies. The process, as it is meant to work, is as follows:

    - user navigates to our site - Site1 - hosted on one server (Server1)
    - the site creates an iframe which connects to another of our hosted sites - Site2 - hosted on Server2
    - Site2 drops its own cookie on the user's machine - Site2 is only connected to via the iframe
    - Site1 drops a cookie on the user's machine

    However, neither cookie is being dropped. We can see that other cookies are being dropped, but neither Site1 nor Site2's cookies are dropped onto the machine. For this reason, I suspect that the problem may be with the iframe.

    Any help on this would be greatly appreciated. Thanks for your help

    --Tara
    Monday, August 19, 2013 10:58 AM

All replies

  • Tools>Internet Options>Security tab, click "reset all zones to default"

    MSIE has a security setting to prevent navigation into zones of lower integrity....

    What security zones do your two sites map to.

    To debug you web applications in IE... f12>Console tab, refresh the page to show suppressed error messages and warnings.

    When asking a question in this forum for questions about html, css and scripting for website development it is helpful if you can provide a link to your website or a mashup so that we can test it.

    see also iframe sandbox attribute


    Rob^_^

    Monday, August 19, 2013 9:10 PM
  • Hi Rob

    Thanks for your reply. I'll provide urls shortly.The url being navigated to is one hosted in house so the security levels should be the same.

    We've tried your suggestion but it didn't make any difference unfortunately.

    --Tara

    Wednesday, August 21, 2013 11:42 AM