locked
AjaxControlToolkit 4.0 VS 2010 No Source Available error RRS feed

  • Question

  • User-1527319102 posted

    I coverted a VS 2008 project to VS 2010.  I then downloaded and installed the AjaxControlToolkit for .net 4.  When I run in debug mode I get an the following error.  Any suggestions would be appreciated.  The code worked in VS 2008 .net 3.5. 


    No Source Available

    There is no source code available for the current location.


    Call stack location:

    AjaxControlToolKitDLL!AjaxControlToolkit.ToolkitScriptManager.OnLoad(System.EventArgs e) Line157

    Source file information:

    Locating source for 'd:\hg\act\Server\AjaxControlToolkit\ToolkitScriptManager\ToolkitScriptManager.cs'. Checksum: MD5 {c1 d2 e2 8c cd 4b 65 11 35 53 7f f5 e3 3b 76 58}

    The file 'd:\hg\act\Server\AjaxControlToolkit\ToolkitScriptManager\ToolkitScriptManager.cs' does not exist.

    Looking in script documents for 'd:\hg\act\Server\AjaxControlToolkit\ToolkitScriptManager\ToolkitScriptManager.cs'...

    Looking in the projects for 'd:\hg\act\Server\AjaxControlToolkit\ToolkitScriptManager\ToolkitScriptManager.cs'.

    The file was not found in a project.

    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\crt\src\'...

    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\atlmfc\src\mfc\'...

    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\atlmfc\src\atl\'...

    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\atlmfc\include\'...

    Looking in directory 'C:\'...

    The debug source files settings for the active solution indicate that the debugger will not ask the user to find the file: d:\hg\act\Server\AjaxControlToolkit\ToolkitScriptManager\ToolkitScriptManager.cs.

    The debugger could not locate the source file 'd:\hg\act\Server\AjaxControlToolkit\ToolkitScriptManager\ToolkitScriptManager.cs'.

    Wednesday, November 3, 2010 5:47 PM

Answers

  • User555306248 posted

    Hope this link helps u

    http://msdn.microsoft.com/en-us/library/3sehk0fb%28VS.80%29.aspx

    http://forums.asp.net/t/1516210.aspx

    "There is no source code available for the current location" means that Visual Studio debugger cannot locate the source file for current location.
    You can try the following ways:

    • Disable debugger to look for source files when debugging (Tools -> Options -> Debugging -> uncheck "Require source files to exactly match the original version").
    • Add the location of this page's source code to "Debug Source Files". (Right-click Solution name in Solution Explorer and select Properties from the shortcut menu. Expand the Common Properties folder, and click the Debug Source Files page)

    For more information about debugging, see http://blogs.msdn.com/jimgries/pages/visual-studio-debugger-faq.aspx (Section: Breakpoints ).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, November 3, 2010 11:25 PM

All replies

  • User555306248 posted

    Hope this link helps u

    http://msdn.microsoft.com/en-us/library/3sehk0fb%28VS.80%29.aspx

    http://forums.asp.net/t/1516210.aspx

    "There is no source code available for the current location" means that Visual Studio debugger cannot locate the source file for current location.
    You can try the following ways:

    • Disable debugger to look for source files when debugging (Tools -> Options -> Debugging -> uncheck "Require source files to exactly match the original version").
    • Add the location of this page's source code to "Debug Source Files". (Right-click Solution name in Solution Explorer and select Properties from the shortcut menu. Expand the Common Properties folder, and click the Debug Source Files page)

    For more information about debugging, see http://blogs.msdn.com/jimgries/pages/visual-studio-debugger-faq.aspx (Section: Breakpoints ).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, November 3, 2010 11:25 PM
  • User1146940846 posted

    No source code d:\hg\act\Server\AjaxControlToolkit\ToolkitScriptManager\ToolkitScriptManager.cs (3.5 error message) 4 has a different file path - from looking at the binary this must be the path it was developed on.

     

    I have been chasing this bug around in AjaxControlToolkit 3.5 and 4 for a couple of weeks and I just fixed it. 

     

    I have 3 pages:

    page 1 - ToolkitScriptManager with a CollapsiblePanelExtender

    page 2 - Does not have any AjaxControlToolkit elements on the page

    page 3 - ToolkitScriptManager with an UpdatePanel.  

    My Code normally goes from page 1 to 2 to 3 but the user can click a "back" button on the page and navigate backwards in the sequence.  some code needs to handle various things during this so I have a response.redirect to navigate from page to page.  I get the no source available at the current location at the end of the page_load code going back from page 3 to 2. 

    I fixed the bug by adding Imports AjaxControlToolkit.ToolkitScriptManager to the page 2 code behind even though it does not have any ajax components on the page. 

    I think what is happening is code execution jumps to page 2 which does not have a ToolkitScriptManager on when I call the the response redirect on page 3, the page 2 page_load runs and finally the code jumps back to run the end sub on page 3 before releasing control to page 2.  Somewhere here something is calling an ajax component but doesn't have any ToolkitScriptManager code available presumably on page 2.

    I have seen other forms of this error message where a component of the toolikit like CollapsiblePanelExtender.  If my fix here doesn't fix it maybe a reference in the page to the component might be needed.

    Hope this helps someone.

     

     

    Wednesday, May 22, 2013 5:32 PM
  • User-1500394302 posted

    Had the same problem with the AjaxControlToolkit downloaded from codeplex . Deleting the pdb file that came with the zip resolved the issue .

    Friday, May 24, 2013 3:21 PM
  • User-1268892327 posted

    Deleting the pdb was the answer for me.  The other two suggestions did not help.

    Monday, November 18, 2013 7:25 PM