none
Cannot install .NET FRAMEWORK 1.1 in VISTA RRS feed

  • Question

  • HI all,

    I downloaded the .Net Framework 1.1 installation file and SP1 from Microsoft website, login as the local administrator for the machine and tried to install the framework but encounter the following error.

     "Application has generated an exception that could not be handled.
    Process id=0x4cc(1228), Thread id=0x904(2308)
    Click OK to terminated
    click cancel to debug the application."

    Got the framework removal tool from one of the KB, tried to remove the framework from the pc, 1. Run the removal tool 2. Restart the vista machine 3. Run the removal tool again Was surprise that the framework wasn't removed from the system?
    I run the framework 1.1 installation file again it still fail at the RegSvc spart.

    I manage to get other few vista machine installed with .NET FRAMEWORK 1.1.

     

    Anyone has any ideal???

     

    Thank you.

     

    Ken

    Monday, October 29, 2007 2:13 PM

Answers

All replies

  • Hi ec7,

    You can try to use the following steps to get the machine back into a known state and then install things back one by one:

    1. Download the .NET Framework cleanup tool and choose to cleanup the version of the .NET Framework that is causing problems on your system
    2. Download and install the version of the .NET Framework that you cleaned up in step 1 (such as the .NET Framework 1.0, .NET Framework 1.1 or .NET Framework 2.0)
    3. (optional) Download and run the .NET Framework verification tool to double-check that all .NET Framework files are correctly installed
    4. Download and install the desired .NET Framework service pack (such as .NET Framework 1.0 SP3 or .NET Framework 1.1 SP1) by running the setup package directly instead of using Windows Update.  Running it directly will allow the service pack setup to display error dialogs instead of having Windows Update suppress them

    Running these steps should ideally put your machine back into a known good state with the .NET Framework plus a service pack installed. For more details, please visit What to do if other .NET Framework setup troubleshooting steps do not help.

    Hope this helps!

    Thanks!

    Wednesday, October 31, 2007 2:14 AM
  • Hi Feng Chen,

     

    Thanks for your reply.

     

    The Step 1, I have tried the .NET Framework cleanup tool , it only applied to Win XP. It does not work in Vista.

     

    SO i am having problem on removing the .NET Framework in Step 1, os i cannot proceed to second step onwards.

     

    Any other way to remove .NET FRAMEWORK 1.1?

     

    Ken

    Wednesday, October 31, 2007 8:15 AM
  • Hi ec7,


    So far as I know, the tool should work with no problem in Vista, have you came across any error in vista? If the UAC pop up a dialog to request your permisson, just select "Allow", then it should work normally.


    Hope this helps!


    Thanks!

    Wednesday, October 31, 2007 8:28 AM
  • Hi Feng Chen,

     

    I have tried to remove .net framework 1.1 using the .Net Framework Removal tool from the forum then i install the framework 1.1 but it sill failed at the stage RegSvc error.

     

    Regards,

    Shaorong Chen

    Wednesday, October 31, 2007 9:41 AM
  • Hi kennynp,

    This issue can be resolved in .NET Framework 1.1 SP1, however you will need to use the following procedure to install both the .NET Framework and the Service Pack at the same time: Download Microsoft .NET Framework 1.1 Redistributable Package and Microsoft .NET Framework 1.1 Service Pack 1 using links below:

    Microsoft .NET Framework 1.1 Redistributable Package and Microsoft .NET Framework 1.1 Service Pack 1.

    1.       Save both installations in the same directory

    2.       Ensure that the Microsoft .NET Framework 1.1 Redistributable Package is named dotnetfx.exe. If not, change its name to dotnetfx.exe.

    3.       Ensure that Microsoft .NET Framework 1.1 Service Pack 1 is named dotnetfxsp1.exe. If not, change its name to dotnetfxsp1.exe.

    4.       Open command prompt as Administrator, and change to the directory where the two installations are saved.

    5.       Run the following commands using the order shown below

    • dotnetfx.exe /c:”msiexec.exe /a netfx.msi TARGETDIR=C:\dotnet”
    • dotnetfxsp1.exe /Xp:C:\dotnet\netfxsp.msp
    • msiexec.exe /a c:\dotnet\netfx.msi /p c:\dotnet\netfxsp.msp

    6.       Install both Microsoft .Net Framework 1.1 and Service Pack 1 by running C:\dotnet\netfx.msi

    There are several references discussed this issue:

    Hope this helps!

    Thanks!

    Wednesday, October 31, 2007 10:08 AM
  • Thanks for the solutions.

     

    I had the similar problem and could not install .Net Framework 1.1 before this.

     

    This one worked well and not errors either. Now able to install VS.Net 2003

     

    Thanks Again

    Thursday, November 1, 2007 12:08 AM
  •  

    Hi Feng Chen,

    I tried solution from Installing Microsoft .Net 1.1 framework on Windows Vista it works!

    Thanks you.

     

    Regards,

    Shaorong Chen

    Thursday, November 1, 2007 4:33 AM