locked
Microsoft Access cannot find the name you entered in the expression. RRS feed

  • Question

  • Access 2013 problems.  The following errors occur when the macro is executed using the commands listed below.  The database contains the Table Scan_ID that contains the field Emp_Bldg_Access.  All other macro commands recognize the table and field except those listed below.  The files are located in the “trusted locations” setup in trust center - options.

    Please provide me with the fix to make both commands work.  Thank you.

    ERROR MESSAGES:

    “The command or action ‘GoToControl’ isn’t available now”

    “Microsoft Access cannot find the name ‘Scan_ID_Bldg_Access’ you entered in the expression.”

    COMMANDS:

    GoToControl

    Control Name Scan_ID.Emp_Bldg_Access

    If ([Scan_ID_Bldg_Access]<>1)

    Monday, January 4, 2016 6:35 PM

Answers

  • Hi. If you're using this command on a Form, make sure the name of the Control is the same as the Field's name. If not, change your code to match the name of the Control rather than the Field's. 

    Hope that helps...

    Tuesday, January 5, 2016 2:37 AM

All replies

  • Hi,

    This is the forum to discuss questions and feedback for Microsoft Office, your issue need some VBA code, I'll move your question to the MSDN forum for Access

    http://social.msdn.microsoft.com/Forums/en-US/home?forum=accessdev&filter=alltypes&sort=lastpostdesc

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.

    George Zhao
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    Tuesday, January 5, 2016 2:11 AM
  • Hi. If you're using this command on a Form, make sure the name of the Control is the same as the Field's name. If not, change your code to match the name of the Control rather than the Field's. 

    Hope that helps...

    Tuesday, January 5, 2016 2:37 AM